ipq807x: move AQR driver from built-in to kmod
authorRobert Marko <robimarko@gmail.com>
Wed, 15 Feb 2023 16:05:30 +0000 (17:05 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 15 Feb 2023 22:29:01 +0000 (23:29 +0100)
ipq807x does not compile-in hwmon core, and this is leading to the hwmon
code in AQR driver not being compiled due to IS_REACHABLE(CONFIG_HWMON)
evaluating to false as hwmon is being built as a module.

So, lets not compile-in Aquantia PHY driver so it can be included as kmod
instead to have functioning hwmon.

This allows using the thermal sensors in AQR-s as thermal zones for
cooling devices like fans.

Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/ipq807x/Makefile
target/linux/ipq807x/config-5.15

index f753cb3f508d3dd27c9d8c850458742754cd8ba6..fdabf575d362c87b44f77fa81b892d6f0851d6c0 100644 (file)
@@ -14,7 +14,7 @@ include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
        kmod-usb3 kmod-usb-dwc3 kmod-usb-dwc3-qcom \
        kmod-leds-gpio kmod-gpio-button-hotplug \
-       kmod-qca-nss-dp \
+       kmod-phy-aquantia kmod-qca-nss-dp \
        ath11k-firmware-ipq8074 kmod-ath11k-ahb \
        wpad-basic-mbedtls uboot-envtools
 
index 923cd935f33e8e155aed10bcd2750ff18eefb8e7..6ab29ebbe6f5d0d04a8fc5ece099a84b5e2e6077 100644 (file)
@@ -1,7 +1,6 @@
 CONFIG_64BIT=y
 # CONFIG_APQ_GCC_8084 is not set
 # CONFIG_APQ_MMCC_8084 is not set
-CONFIG_AQUANTIA_PHY=y
 CONFIG_ARCH_DMA_ADDR_T_64BIT=y
 CONFIG_ARCH_HIBERNATION_POSSIBLE=y
 CONFIG_ARCH_KEEP_MEMBLOCK=y