imx6: add Gateworks GW551x support
authorLuka Perkov <luka@openwrt.org>
Wed, 18 Nov 2015 21:35:09 +0000 (21:35 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 18 Nov 2015 21:35:09 +0000 (21:35 +0000)
Upstream patch: e9d6d6b62f306ba83e1441af5daf2809a6167474

Add support for the Gateworks GW5510 board featuring:
 * i.MX6 SoC
 * up to 512MB DDR3
 * up to 2GB NAND flash
 * 1x miniPCIe socket (with USB)
 * HDMI out (micro-HDMI)
 * HDMI in (micro-HDMI) (currently supported by only vendor kernel)
 * TTL level I/O (supported by GW16111 breakout board):
  * I2C
  * 2x UART
  * CAN
  * 2x DIO (GPIO/PWM)
  * USB OTG

Also add support to OpenWrt build system

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
SVN-Revision: 47505

target/linux/imx6/base-files/lib/imx6.sh
target/linux/imx6/patches-4.1/020-ARM-dts-Gateworks-GW5510-support-i.MX6.patch [new file with mode: 0644]
target/linux/imx6/profiles/120-gateworks.mk

index 360ec587950140ed8d34835e0487be5f3adb769a..32440aab9cd3f0a1251c78045d624811b0c43575 100755 (executable)
@@ -34,6 +34,11 @@ imx6_board_detect() {
                name="gw54xx"
                ;;
 
                name="gw54xx"
                ;;
 
+       "Gateworks Ventana i.MX6 Dual/Quad GW551X" |\
+       "Gateworks Ventana i.MX6 Solo/DualLite GW551X")
+               name="gw551x"
+               ;;
+
        "Gateworks Ventana i.MX6 DualLite/Solo GW552X" |\
        "Gateworks Ventana i.MX6 Dual/Quad GW552X")
                name="gw552x"
        "Gateworks Ventana i.MX6 DualLite/Solo GW552X" |\
        "Gateworks Ventana i.MX6 Dual/Quad GW552X")
                name="gw552x"
diff --git a/target/linux/imx6/patches-4.1/020-ARM-dts-Gateworks-GW5510-support-i.MX6.patch b/target/linux/imx6/patches-4.1/020-ARM-dts-Gateworks-GW5510-support-i.MX6.patch
new file mode 100644 (file)
index 0000000..551b221
--- /dev/null
@@ -0,0 +1,500 @@
+From e9d6d6b62f306ba83e1441af5daf2809a6167474 Mon Sep 17 00:00:00 2001
+From: Tim Harvey <tharvey@gateworks.com>
+Date: Thu, 7 May 2015 08:38:00 -0700
+Subject: [PATCH] ARM: dts: Gateworks GW5510 support (i.MX6)
+
+Add support for the Gateworks GW5510 board featuring:
+ * i.MX6 SoC
+ * up to 512MB DDR3
+ * up to 2GB NAND flash
+ * 1x miniPCIe socket (with USB)
+ * HDMI out (micro-HDMI)
+ * HDMI in (micro-HDMI) (currently supported by only vendor kernel)
+ * TTL level I/O (supported by GW16111 breakout board):
+  * I2C
+  * 2x UART
+  * CAN
+  * 2x DIO (GPIO/PWM)
+  * USB OTG
+
+For more details see:
+ http://www.gateworks.com/product/item/ventana-gw5510-single-board-computer
+
+Signed-off-by: Tim Harvey <tharvey@gateworks.com>
+Reviewed-by: Fabio Estevam <fabio.estevam@freescale.com>
+Signed-off-by: Shawn Guo <shawn.guo@linaro.org>
+---
+ arch/arm/boot/dts/Makefile            |   2 +
+ arch/arm/boot/dts/imx6dl-gw551x.dts   |  55 ++++++
+ arch/arm/boot/dts/imx6q-gw551x.dts    |  55 ++++++
+ arch/arm/boot/dts/imx6qdl-gw551x.dtsi | 314 ++++++++++++++++++++++++++++++++++
+ 4 files changed, 426 insertions(+)
+ create mode 100644 arch/arm/boot/dts/imx6dl-gw551x.dts
+ create mode 100644 arch/arm/boot/dts/imx6q-gw551x.dts
+ create mode 100644 arch/arm/boot/dts/imx6qdl-gw551x.dtsi
+
+diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
+index 86217db..8932e6e 100644
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -262,6 +262,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
+       imx6dl-gw52xx.dtb \
+       imx6dl-gw53xx.dtb \
+       imx6dl-gw54xx.dtb \
++      imx6dl-gw551x.dtb \
+       imx6dl-gw552x.dtb \
+       imx6dl-hummingboard.dtb \
+       imx6dl-nitrogen6x.dtb \
+@@ -288,6 +289,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
+       imx6q-gw53xx.dtb \
+       imx6q-gw5400-a.dtb \
+       imx6q-gw54xx.dtb \
++      imx6q-gw551x.dtb \
+       imx6q-gw552x.dtb \
+       imx6q-hummingboard.dtb \
+       imx6q-nitrogen6x.dtb \
+diff --git a/arch/arm/boot/dts/imx6dl-gw551x.dts b/arch/arm/boot/dts/imx6dl-gw551x.dts
+new file mode 100644
+index 0000000..82d5f85
+--- /dev/null
++++ b/arch/arm/boot/dts/imx6dl-gw551x.dts
+@@ -0,0 +1,55 @@
++/*
++ * Copyright 2014 Gateworks Corporation
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of
++ *     the License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ *     You should have received a copy of the GNU General Public
++ *     License along with this file; if not, write to the Free
++ *     Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
++ *     MA 02110-1301 USA
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "imx6dl.dtsi"
++#include "imx6qdl-gw551x.dtsi"
++
++/ {
++      model = "Gateworks Ventana i.MX6 DualLite/Solo GW551X";
++      compatible = "gw,imx6dl-gw551x", "gw,ventana", "fsl,imx6dl";
++};
+diff --git a/arch/arm/boot/dts/imx6q-gw551x.dts b/arch/arm/boot/dts/imx6q-gw551x.dts
+new file mode 100644
+index 0000000..2c7feee
+--- /dev/null
++++ b/arch/arm/boot/dts/imx6q-gw551x.dts
+@@ -0,0 +1,55 @@
++/*
++ * Copyright 2014 Gateworks Corporation
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of
++ *     the License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ *     You should have received a copy of the GNU General Public
++ *     License along with this file; if not, write to the Free
++ *     Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
++ *     MA 02110-1301 USA
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "imx6q.dtsi"
++#include "imx6qdl-gw551x.dtsi"
++
++/ {
++      model = "Gateworks Ventana i.MX6 Dual/Quad GW551X";
++      compatible = "gw,imx6q-gw551x", "gw,ventana", "fsl,imx6q";
++};
+diff --git a/arch/arm/boot/dts/imx6qdl-gw551x.dtsi b/arch/arm/boot/dts/imx6qdl-gw551x.dtsi
+new file mode 100644
+index 0000000..d1866a0
+--- /dev/null
++++ b/arch/arm/boot/dts/imx6qdl-gw551x.dtsi
+@@ -0,0 +1,314 @@
++/*
++ * Copyright 2014 Gateworks Corporation
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of
++ *     the License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ *     You should have received a copy of the GNU General Public
++ *     License along with this file; if not, write to the Free
++ *     Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
++ *     MA 02110-1301 USA
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++#include <dt-bindings/gpio/gpio.h>
++
++/ {
++      /* these are used by bootloader for disabling nodes */
++      aliases {
++              led0 = &led0;
++              nand = &gpmi;
++              ssi0 = &ssi1;
++              usb0 = &usbh1;
++              usb1 = &usbotg;
++      };
++
++      chosen {
++              bootargs = "console=ttymxc1,115200";
++      };
++
++      leds {
++              compatible = "gpio-leds";
++              pinctrl-names = "default";
++              pinctrl-0 = <&pinctrl_gpio_leds>;
++
++              led0: user1 {
++                      label = "user1";
++                      gpios = <&gpio4 7 GPIO_ACTIVE_LOW>;
++                      default-state = "on";
++                      linux,default-trigger = "heartbeat";
++              };
++      };
++
++      memory {
++              reg = <0x10000000 0x20000000>;
++      };
++
++      regulators {
++              compatible = "simple-bus";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              reg_5p0v: regulator@0 {
++                      compatible = "regulator-fixed";
++                      reg = <0>;
++                      regulator-name = "5P0V";
++                      regulator-min-microvolt = <5000000>;
++                      regulator-max-microvolt = <5000000>;
++              };
++
++              reg_usb_h1_vbus: regulator@1 {
++                      compatible = "regulator-fixed";
++                      reg = <1>;
++                      regulator-name = "usb_h1_vbus";
++                      regulator-min-microvolt = <5000000>;
++                      regulator-max-microvolt = <5000000>;
++              };
++
++              reg_usb_otg_vbus: regulator@2 {
++                      compatible = "regulator-fixed";
++                      reg = <2>;
++                      regulator-name = "usb_otg_vbus";
++                      regulator-min-microvolt = <5000000>;
++                      regulator-max-microvolt = <5000000>;
++              };
++      };
++};
++
++&can1 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_flexcan1>;
++      status = "okay";
++};
++
++&gpmi {
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_gpmi_nand>;
++      status = "okay";
++};
++
++&hdmi {
++      ddc-i2c-bus = <&i2c3>;
++      status = "okay";
++};
++
++&i2c1 {
++      clock-frequency = <100000>;
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_i2c1>;
++      status = "okay";
++
++      eeprom1: eeprom@50 {
++              compatible = "atmel,24c02";
++              reg = <0x50>;
++              pagesize = <16>;
++      };
++
++      eeprom2: eeprom@51 {
++              compatible = "atmel,24c02";
++              reg = <0x51>;
++              pagesize = <16>;
++      };
++
++      eeprom3: eeprom@52 {
++              compatible = "atmel,24c02";
++              reg = <0x52>;
++              pagesize = <16>;
++      };
++
++      eeprom4: eeprom@53 {
++              compatible = "atmel,24c02";
++              reg = <0x53>;
++              pagesize = <16>;
++      };
++
++      gpio: pca9555@23 {
++              compatible = "nxp,pca9555";
++              reg = <0x23>;
++              gpio-controller;
++              #gpio-cells = <2>;
++      };
++
++      rtc: ds1672@68 {
++              compatible = "dallas,ds1672";
++              reg = <0x68>;
++      };
++};
++
++&i2c2 {
++      clock-frequency = <100000>;
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_i2c2>;
++      status = "okay";
++};
++
++&i2c3 {
++      clock-frequency = <100000>;
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_i2c3>;
++      status = "okay";
++
++      gpio_exp: pca9555@24 {
++              compatible = "nxp,pca9555";
++              reg = <0x24>;
++              gpio-controller;
++              #gpio-cells = <2>;
++      };
++
++};
++
++&pcie {
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_pcie>;
++      reset-gpio = <&gpio1 0 GPIO_ACTIVE_LOW>;
++      status = "okay";
++};
++
++&ssi1 {
++      status = "okay";
++};
++
++&uart2 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_uart2>;
++      status = "okay";
++};
++
++&uart3 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_uart3>;
++      status = "okay";
++};
++
++&usbotg {
++      vbus-supply = <&reg_usb_otg_vbus>;
++      pinctrl-names = "default";
++      pinctrl-0 = <&pinctrl_usbotg>;
++      disable-over-current;
++      status = "okay";
++};
++
++&usbh1 {
++      vbus-supply = <&reg_usb_h1_vbus>;
++      status = "okay";
++};
++
++&iomuxc {
++      imx6qdl-gw51xx {
++              pinctrl_flexcan1: flexcan1grp {
++                      fsl,pins = <
++                              MX6QDL_PAD_KEY_ROW2__FLEXCAN1_RX        0x1b0b1
++                              MX6QDL_PAD_KEY_COL2__FLEXCAN1_TX        0x1b0b1
++                              MX6QDL_PAD_GPIO_9__GPIO1_IO09           0x4001b0b0 /* CAN_STBY */
++                      >;
++              };
++
++              pinctrl_gpio_leds: gpioledsgrp {
++                      fsl,pins = <
++                              MX6QDL_PAD_KEY_ROW0__GPIO4_IO07   0x1b0b0
++                      >;
++              };
++
++              pinctrl_gpmi_nand: gpminandgrp {
++                      fsl,pins = <
++                              MX6QDL_PAD_NANDF_CLE__NAND_CLE          0xb0b1
++                              MX6QDL_PAD_NANDF_ALE__NAND_ALE          0xb0b1
++                              MX6QDL_PAD_NANDF_WP_B__NAND_WP_B        0xb0b1
++                              MX6QDL_PAD_NANDF_RB0__NAND_READY_B      0xb000
++                              MX6QDL_PAD_NANDF_CS0__NAND_CE0_B        0xb0b1
++                              MX6QDL_PAD_NANDF_CS1__NAND_CE1_B        0xb0b1
++                              MX6QDL_PAD_SD4_CMD__NAND_RE_B           0xb0b1
++                              MX6QDL_PAD_SD4_CLK__NAND_WE_B           0xb0b1
++                              MX6QDL_PAD_NANDF_D0__NAND_DATA00        0xb0b1
++                              MX6QDL_PAD_NANDF_D1__NAND_DATA01        0xb0b1
++                              MX6QDL_PAD_NANDF_D2__NAND_DATA02        0xb0b1
++                              MX6QDL_PAD_NANDF_D3__NAND_DATA03        0xb0b1
++                              MX6QDL_PAD_NANDF_D4__NAND_DATA04        0xb0b1
++                              MX6QDL_PAD_NANDF_D5__NAND_DATA05        0xb0b1
++                              MX6QDL_PAD_NANDF_D6__NAND_DATA06        0xb0b1
++                              MX6QDL_PAD_NANDF_D7__NAND_DATA07        0xb0b1
++                      >;
++              };
++
++              pinctrl_i2c1: i2c1grp {
++                      fsl,pins = <
++                              MX6QDL_PAD_EIM_D21__I2C1_SCL            0x4001b8b1
++                              MX6QDL_PAD_EIM_D28__I2C1_SDA            0x4001b8b1
++                      >;
++              };
++
++              pinctrl_i2c2: i2c2grp {
++                      fsl,pins = <
++                              MX6QDL_PAD_KEY_COL3__I2C2_SCL           0x4001b8b1
++                              MX6QDL_PAD_KEY_ROW3__I2C2_SDA           0x4001b8b1
++                      >;
++              };
++
++              pinctrl_i2c3: i2c3grp {
++                      fsl,pins = <
++                              MX6QDL_PAD_GPIO_3__I2C3_SCL             0x4001b8b1
++                              MX6QDL_PAD_GPIO_6__I2C3_SDA             0x4001b8b1
++                      >;
++              };
++
++              pinctrl_pcie: pciegrp {
++                      fsl,pins = <
++                              MX6QDL_PAD_GPIO_0__GPIO1_IO00           0x1b0b0 /* PCIE RST */
++                      >;
++              };
++
++              pinctrl_uart2: uart2grp {
++                      fsl,pins = <
++                              MX6QDL_PAD_SD4_DAT7__UART2_TX_DATA      0x1b0b1
++                              MX6QDL_PAD_SD4_DAT4__UART2_RX_DATA      0x1b0b1
++                      >;
++              };
++
++              pinctrl_uart3: uart3grp {
++                      fsl,pins = <
++                              MX6QDL_PAD_EIM_D24__UART3_TX_DATA       0x1b0b1
++                              MX6QDL_PAD_EIM_D25__UART3_RX_DATA       0x1b0b1
++                      >;
++              };
++
++              pinctrl_usbotg: usbotggrp {
++                      fsl,pins = <
++                              MX6QDL_PAD_GPIO_1__USB_OTG_ID           0x17059
++                      >;
++              };
++      };
++};
+-- 
+2.5.1
+
index 115021af9cb56f30fcb5b92332245eedf45a9461..735538409bfd788422aa90762c6790e7da677cc4 100644 (file)
@@ -41,12 +41,14 @@ VENTANA_DTS:= \
        imx6dl-gw52xx \
        imx6dl-gw53xx \
        imx6dl-gw54xx \
        imx6dl-gw52xx \
        imx6dl-gw53xx \
        imx6dl-gw54xx \
+       imx6dl-gw551x \
        imx6dl-gw552x \
        imx6q-gw51xx \
        imx6q-gw52xx \
        imx6q-gw53xx \
        imx6q-gw54xx \
        imx6q-gw5400-a \
        imx6dl-gw552x \
        imx6q-gw51xx \
        imx6q-gw52xx \
        imx6q-gw53xx \
        imx6q-gw54xx \
        imx6q-gw5400-a \
+       imx6q-gw551x \
        imx6q-gw552x
 
 $(eval $(call Profile,VENTANA))
        imx6q-gw552x
 
 $(eval $(call Profile,VENTANA))