kernel: bump 4.9 to 4.9.208
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 4 Jan 2020 22:19:42 +0000 (23:19 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 4 Jan 2020 23:03:22 +0000 (00:03 +0100)
Refreshed all patches.

Compile-tested on: lantiq
Runtime-tested on: lantiq

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0009-spidev-Add-spidev-compatible-string-to-silence-warni.patch
target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/generic/pending-4.9/130-add-linux-spidev-compatible-si3210.patch
target/linux/generic/pending-4.9/203-kallsyms_uncompressed.patch
target/linux/generic/pending-4.9/630-packet_socket_type.patch
target/linux/layerscape/patches-4.9/812-mmc-layerscape-support.patch

index c800dc64b14183ab08fcb15b61616a93b24ae100..88649e6309ae74bc7cb66b32cfe6b7ae5bb4cf7a 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .207
+LINUX_VERSION-4.9 = .208
 LINUX_VERSION-4.14 = .162
 
-LINUX_KERNEL_HASH-4.9.207 = ca86637e7b5bec65eeb7da695824e0e8aca5ba52eb742885f0b7241977400124
+LINUX_KERNEL_HASH-4.9.208 = b7ad1c9841d671d026c55a4c91c77205f8b488ca5f980f838591c68662e0525a
 LINUX_KERNEL_HASH-4.14.162 = f65170224cd4359ce8b2793b492bd8127abdd0b91350484e001bce13f0c98b4b
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 0c5f0eef10c63c88000700dc6da36e63d7b5c76f..653d02f22c515946c6c10b64cb279514127c23e2 100644 (file)
@@ -10,7 +10,7 @@ See: https://github.com/raspberrypi/linux/issues/1054
 
 --- a/drivers/spi/spidev.c
 +++ b/drivers/spi/spidev.c
-@@ -697,6 +697,7 @@ static const struct of_device_id spidev_
+@@ -700,6 +700,7 @@ static const struct of_device_id spidev_
        { .compatible = "rohm,dh2228fv" },
        { .compatible = "lineartechnology,ltc2488" },
        { .compatible = "siliconlabs,si3210" },
index 8beceff0fa481f2c628405210d0276a440e94c08..4ac95d3ee44ed623d91bf3c38fd13687719b6660 100644 (file)
@@ -134,7 +134,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (tcp_small_queue_check(sk, skb, 0))
                        break;
  
-@@ -3561,8 +3561,6 @@ void __tcp_send_ack(struct sock *sk, u32
+@@ -3569,8 +3569,6 @@ void __tcp_send_ack(struct sock *sk, u32
        /* We do not want pure acks influencing TCP Small Queues or fq/pacing
         * too much.
         * SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
index 308dd0f194f1da13dcf1b9dc8648012f93838374..433788e07570e95554eac2effd3b8033828cebf3 100644 (file)
@@ -1293,7 +1293,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
 --- a/drivers/net/fjes/fjes_main.c
 +++ b/drivers/net/fjes/fjes_main.c
-@@ -1122,7 +1122,7 @@ static int fjes_poll(struct napi_struct
+@@ -1125,7 +1125,7 @@ static int fjes_poll(struct napi_struct
        }
  
        if (work_done < budget) {
index b3de75fbbe46b1863c6fe5a7d7592b71573ed0e8..e81597685526e86e193fa81350fdae55374fcee5 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
 
 --- a/drivers/spi/spidev.c
 +++ b/drivers/spi/spidev.c
-@@ -696,6 +696,7 @@ static struct class *spidev_class;
+@@ -699,6 +699,7 @@ static struct class *spidev_class;
  static const struct of_device_id spidev_dt_ids[] = {
        { .compatible = "rohm,dh2228fv" },
        { .compatible = "lineartechnology,ltc2488" },
index 759357549bedb406540507fbe668fb0f209eacda..9bc8055039ea71295caf1acd0fa704683ba86e57 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        output_label("kallsyms_token_table");
        off = 0;
        for (i = 0; i < 256; i++) {
-@@ -507,6 +511,9 @@ static void *find_token(unsigned char *s
+@@ -509,6 +513,9 @@ static void *find_token(unsigned char *s
  {
        int i;
  
@@ -85,7 +85,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        for (i = 0; i < len - 1; i++) {
                if (str[i] == token[0] && str[i+1] == token[1])
                        return &str[i];
-@@ -579,6 +586,9 @@ static void optimize_result(void)
+@@ -581,6 +588,9 @@ static void optimize_result(void)
  {
        int i, best;
  
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        /* using the '\0' symbol last allows compress_symbols to use standard
         * fast string functions */
        for (i = 255; i >= 0; i--) {
-@@ -767,6 +777,8 @@ int main(int argc, char **argv)
+@@ -769,6 +779,8 @@ int main(int argc, char **argv)
                                symbol_prefix_char = *p;
                        } else if (strcmp(argv[i], "--base-relative") == 0)
                                base_relative = 1;
index e61bde07747d8588c55b5b040ef4c502ed40b468..e89bf0cfaa263399e98a349267b581d609037b40 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #define PACKET_FANOUT_LB              1
 --- a/net/packet/af_packet.c
 +++ b/net/packet/af_packet.c
-@@ -1780,6 +1780,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1781,6 +1781,7 @@ static int packet_rcv_spkt(struct sk_buf
  {
        struct sock *sk;
        struct sockaddr_pkt *spkt;
@@ -38,7 +38,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        /*
         *      When we registered the protocol we saved the socket in the data
-@@ -1787,6 +1788,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1788,6 +1789,7 @@ static int packet_rcv_spkt(struct sk_buf
         */
  
        sk = pt->af_packet_priv;
@@ -46,7 +46,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        /*
         *      Yank back the headers [hope the device set this
-@@ -1799,7 +1801,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1800,7 +1802,7 @@ static int packet_rcv_spkt(struct sk_buf
         *      so that this procedure is noop.
         */
  
@@ -55,7 +55,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                goto out;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -2037,12 +2039,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -2038,12 +2040,12 @@ static int packet_rcv(struct sk_buff *sk
        unsigned int snaplen, res;
        bool is_drop_n_account = false;
  
@@ -71,7 +71,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2168,12 +2170,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2169,12 +2171,12 @@ static int tpacket_rcv(struct sk_buff *s
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3291,6 +3293,7 @@ static int packet_create(struct net *net
+@@ -3292,6 +3294,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3904,6 +3907,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3905,6 +3908,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3956,6 +3969,13 @@ static int packet_getsockopt(struct sock
+@@ -3957,6 +3970,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 71e4e2a8d1eb9a8a0497b5bfeddb362e5503dd1a..5971fdcbe7d584c041c21d49c877ff5111de8199 100644 (file)
@@ -482,7 +482,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        sdhci_get_of_property(pdev);
 --- a/drivers/mmc/host/sdhci.c
 +++ b/drivers/mmc/host/sdhci.c
-@@ -1631,26 +1631,24 @@ static void sdhci_set_ios(struct mmc_hos
+@@ -1629,26 +1629,24 @@ static void sdhci_set_ios(struct mmc_hos
  
        ctrl = sdhci_readb(host, SDHCI_HOST_CONTROL);
  
@@ -523,7 +523,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                if (!host->preset_enabled) {
                        sdhci_writeb(host, ctrl, SDHCI_HOST_CONTROL);
                        /*
-@@ -1963,7 +1961,7 @@ static int sdhci_prepare_hs400_tuning(st
+@@ -1961,7 +1959,7 @@ static int sdhci_prepare_hs400_tuning(st
        return 0;
  }
  
@@ -532,7 +532,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        struct sdhci_host *host = mmc_priv(mmc);
        u16 ctrl;
-@@ -2022,6 +2020,9 @@ static int sdhci_execute_tuning(struct m
+@@ -2020,6 +2018,9 @@ static int sdhci_execute_tuning(struct m
                return err;
        }
  
@@ -542,7 +542,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        ctrl = sdhci_readw(host, SDHCI_HOST_CONTROL2);
        ctrl |= SDHCI_CTRL_EXEC_TUNING;
        if (host->quirks2 & SDHCI_QUIRK2_TUNING_WORK_AROUND)
-@@ -2134,9 +2135,10 @@ static int sdhci_execute_tuning(struct m
+@@ -2132,9 +2133,10 @@ static int sdhci_execute_tuning(struct m
  
                ctrl = sdhci_readw(host, SDHCI_HOST_CONTROL2);
  
@@ -556,7 +556,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        } while (ctrl & SDHCI_CTRL_EXEC_TUNING);
  
        /*
-@@ -2172,6 +2174,7 @@ out_unlock:
+@@ -2170,6 +2172,7 @@ out_unlock:
        spin_unlock_irqrestore(&host->lock, flags);
        return err;
  }
@@ -564,7 +564,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  static int sdhci_select_drive_strength(struct mmc_card *card,
                                       unsigned int max_dtr, int host_drv,
-@@ -2996,6 +2999,8 @@ struct sdhci_host *sdhci_alloc_host(stru
+@@ -2994,6 +2997,8 @@ struct sdhci_host *sdhci_alloc_host(stru
  
        host->flags = SDHCI_SIGNALING_330;