iproute2: q_cake: Add printing of no-split-gso option
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 12 Sep 2018 07:24:37 +0000 (08:24 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 12 Sep 2018 08:13:44 +0000 (09:13 +0100)
When the GSO splitting was turned into dual split-gso/no-split-gso options,
the printing of the latter was left out. Add that, so output is consistent
with the options passed

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/190-add-cake-to-tc.patch

index ac313107832fdc05a98c5a8fd0db61885da28f4c..5ed9556043d191a776f925567b5d98881868cc90 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.18.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
index fa09b4d867571d11e30e5b81bb4698805a78052d..f61168c696f67f72092be8c820299e5a7ec64289 100644 (file)
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,799 @@
+@@ -0,0 +1,801 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
 +
 +      if (split_gso)
 +              print_string(PRINT_FP, NULL, "split-gso ", NULL);
++      else
++              print_string(PRINT_FP, NULL, "no-split-gso ", NULL);
 +      print_bool(PRINT_JSON, "split_gso", NULL, split_gso);
 +
 +      if (interval)