gettext-full: use uclibc workarounds for musl as well
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2014 22:25:43 +0000 (22:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2014 22:25:43 +0000 (22:25 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41397

package/libs/gettext-full/Makefile

index 11dc1f564360060c935b978e36ee407135227a18..ca521b4c52d23b2f19acd74d49d506d7373a1134 100644 (file)
@@ -38,6 +38,9 @@ TARGET_CFLAGS += $(FPIC)
 ifneq ($(HOST_OS),Linux)
   TARGET_CFLAGS += -I$(STAGING_DIR_HOST)/include
 endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \