package/iptables: upgrade to iptables version 1.4.9
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 4 Aug 2010 13:29:07 +0000 (13:29 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 4 Aug 2010 13:29:07 +0000 (13:29 +0000)
SVN-Revision: 22482

package/iptables/Makefile
package/iptables/patches/030-no-libnfnetlink.patch

index f9c96adbdfb85de2442954a01956be863f0b84d9..3c4a22ff85e3ed56c07d16358a0ff367835462a1 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
-PKG_VERSION:=1.4.8
+PKG_VERSION:=1.4.9
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_MD5SUM:=697ed89f37af4473a5f6349ba2700f2d
+PKG_MD5SUM:=db1312f7ce5a4c11dc981a2ac76b26e8
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
index 4ddea3a6635d36249e6fadea220e4af0ffbcd8d2..07bed666cae2dcc31923cb48cbfcde0655ef4a0c 100644 (file)
@@ -1,18 +1,17 @@
 --- a/configure
 +++ b/configure
 --- a/configure
 +++ b/configure
-@@ -10853,77 +10853,7 @@ $as_echo "no" >&6; }
+@@ -10864,75 +10864,7 @@ $as_echo "no" >&6; }
+       fi
  fi
  
 -pkg_failed=no
 -{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
 -$as_echo_n "checking for libnfnetlink... " >&6; }
 -
  fi
  
 -pkg_failed=no
 -{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
 -$as_echo_n "checking for libnfnetlink... " >&6; }
 -
--if test -n "$PKG_CONFIG"; then
--    if test -n "$libnfnetlink_CFLAGS"; then
--        pkg_cv_libnfnetlink_CFLAGS="$libnfnetlink_CFLAGS"
--    else
--        if test -n "$PKG_CONFIG" && \
+-if test -n "$libnfnetlink_CFLAGS"; then
+-    pkg_cv_libnfnetlink_CFLAGS="$libnfnetlink_CFLAGS"
+- elif test -n "$PKG_CONFIG"; then
+-    if test -n "$PKG_CONFIG" && \
 -    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
 -  ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
 -  ac_status=$?
 -    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
 -  ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
 -  ac_status=$?
 -else
 -  pkg_failed=yes
 -fi
 -else
 -  pkg_failed=yes
 -fi
--    fi
--else
--      pkg_failed=untried
+- else
+-    pkg_failed=untried
 -fi
 -fi
--if test -n "$PKG_CONFIG"; then
--    if test -n "$libnfnetlink_LIBS"; then
--        pkg_cv_libnfnetlink_LIBS="$libnfnetlink_LIBS"
--    else
--        if test -n "$PKG_CONFIG" && \
+-if test -n "$libnfnetlink_LIBS"; then
+-    pkg_cv_libnfnetlink_LIBS="$libnfnetlink_LIBS"
+- elif test -n "$PKG_CONFIG"; then
+-    if test -n "$PKG_CONFIG" && \
 -    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
 -  ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
 -  ac_status=$?
 -    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
 -  ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
 -  ac_status=$?
 -else
 -  pkg_failed=yes
 -fi
 -else
 -  pkg_failed=yes
 -fi
--    fi
--else
--      pkg_failed=untried
+- else
+-    pkg_failed=untried
 -fi
 -
 -
 -
 -if test $pkg_failed = yes; then
 -fi
 -
 -
 -
 -if test $pkg_failed = yes; then
+-      { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
 -
 -if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
 -        _pkg_short_errors_supported=yes
 -
 -if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
 -        _pkg_short_errors_supported=yes
 -        _pkg_short_errors_supported=no
 -fi
 -        if test $_pkg_short_errors_supported = yes; then
 -        _pkg_short_errors_supported=no
 -fi
 -        if test $_pkg_short_errors_supported = yes; then
--              libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libnfnetlink >= 1.0"`
+-              libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnfnetlink >= 1.0" 2>&1`
 -        else
 -        else
--              libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libnfnetlink >= 1.0"`
+-              libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnfnetlink >= 1.0" 2>&1`
 -        fi
 -      # Put the nasty error message in config.log where it belongs
 -      echo "$libnfnetlink_PKG_ERRORS" >&5
 -
 -        fi
 -      # Put the nasty error message in config.log where it belongs
 -      echo "$libnfnetlink_PKG_ERRORS" >&5
 -
--      { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--                nfnetlink=0
+-      nfnetlink=0
 -elif test $pkg_failed = untried; then
 -elif test $pkg_failed = untried; then
+-      { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
 -      nfnetlink=0
 -else
 -      libnfnetlink_CFLAGS=$pkg_cv_libnfnetlink_CFLAGS
 -      nfnetlink=0
 -else
 -      libnfnetlink_CFLAGS=$pkg_cv_libnfnetlink_CFLAGS