ar71xx: remove obsolete '< KERNEL_VERSION(4, 2, 0)' check
authorGabor Juhos <juhosg@freemail.hu>
Tue, 9 Jan 2018 20:20:13 +0000 (21:20 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 9 Jan 2018 20:33:18 +0000 (21:33 +0100)
Because the oldest supported kernel version on the ar71xx target is 4.4,
the condition that the kernel version is smaller than 4.2.0 is always
false. Remove the obsolete check from ag71xx_main.c to clean up the code
a bit.

Signed-off-by: Gabor Juhos <juhosg@freemail.hu>
target/linux/ar71xx/files/drivers/net/ethernet/atheros/ag71xx/ag71xx_main.c

index 72dd654a691355c881b15d796fad0d640e05fc15..93f8c5305d1f988255ee1a5045c6123d18f1acd9 100644 (file)
 
 #include "ag71xx.h"
 
 
 #include "ag71xx.h"
 
-#if LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0)
-static inline void skb_free_frag(void *data)
-{
-       put_page(virt_to_head_page(data));
-}
-#endif
-
 #define AG71XX_DEFAULT_MSG_ENABLE      \
        (NETIF_MSG_DRV                  \
        | NETIF_MSG_PROBE               \
 #define AG71XX_DEFAULT_MSG_ENABLE      \
        (NETIF_MSG_DRV                  \
        | NETIF_MSG_PROBE               \