ramips: mt7621: enable lzma-loader for netis WF2881
authorJoonhyuk Song <thenoface303@gmail.com>
Mon, 21 Nov 2022 02:37:36 +0000 (11:37 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 6 Dec 2022 22:29:42 +0000 (23:29 +0100)
Fixes boot loader LZMA decompression issues (LZMA ERROR 1)

Signed-off-by: Joonhyuk Song <thenoface303@gmail.com>
(cherry picked from commit 25ede5170d5fbfd233ba21f7a294ec3a2ddeb635)

target/linux/ramips/image/mt7621.mk

index 4057c4ea11b29233be7673a77fc2c8100209d8b3..ab131658e064f94651057d0409942b7b7133a346 100644 (file)
@@ -1448,6 +1448,7 @@ TARGET_DEVICES += netgear_wndr3700-v5
 
 define Device/netis_wf2881
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   FILESYSTEMS := squashfs
@@ -1455,7 +1456,7 @@ define Device/netis_wf2881
   IMAGE_SIZE := 129280k
   UBINIZE_OPTS := -E 5
   UIMAGE_NAME := WF2881_0.0.00
-  KERNEL_INITRAMFS := $(KERNEL_DTB) | netis-tail WF2881 | uImage lzma
+  KERNEL_INITRAMFS := $$(KERNEL) | netis-tail WF2881
   IMAGES += factory.bin
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \