kernel: update linux 3.3 to 3.3.3
authorJonas Gorski <jogo@openwrt.org>
Tue, 24 Apr 2012 09:25:38 +0000 (09:25 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 24 Apr 2012 09:25:38 +0000 (09:25 +0000)
SVN-Revision: 31460

17 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/at91/patches/700-tqma9263-support.patch
target/linux/at91/patches/805-free_some_portc_pins.patch [changed mode: 0755->0644]
target/linux/at91/patches/900-AT91-Add-external-RTC-for-Flexibity-board.patch
target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
target/linux/avr32/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.3/811-pci_disable_usb_common_quirks.patch
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ramips/Makefile
target/linux/uml/Makefile
target/linux/uml/patches-3.3/901-lib_zlib_deflate_visible.patch
target/linux/x86/geos/target.mk

index 1dd70f6c5d0bdace7e4faeb5f49116f060887489..cb8691a40ea0aba2924568acaba961ac9bcdaacd 100644 (file)
@@ -38,8 +38,8 @@ endif
 ifeq ($(LINUX_VERSION),3.2.16)
   LINUX_KERNEL_MD5SUM:=246e6bd28ea44c90ec66c7f8b56e4803
 endif
-ifeq ($(LINUX_VERSION),3.3.2)
-  LINUX_KERNEL_MD5SUM:=cb5f959dfb3009bcc2a6e4ebf162174e
+ifeq ($(LINUX_VERSION),3.3.3)
+  LINUX_KERNEL_MD5SUM:=a6897310b4785b5f912c567cdc93402e
 endif
 
 # disable the md5sum check for unknown kernel versions
index ae7fe1cd62ea27b612ab3dd0f95d6ee8516050dc..c7eb8e2dff9303f14124a22eefcefa8d9402f878 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 71b967c07d728d0063a8c98748951928c8baa16a..3151fb88fd1c3f949ca0fa692ba1f8544b2c3ef2 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 SUBTARGETS:=9g20 9260 9263
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 649d0d77da51190e4836a201c0663c149e2461b7..321fe59a4f40d97bb0d8a30d2578ae8d6b27cdfd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-at91/Kconfig
 +++ b/arch/arm/mach-at91/Kconfig
-@@ -318,6 +318,12 @@ config MACH_NEOCORE926
+@@ -335,6 +335,12 @@ config MACH_NEOCORE926
        help
          Select this if you are using the Adeneo Neocore 926 board.
  
@@ -15,9 +15,9 @@
  # ----------------------------------------------------------
 --- a/arch/arm/mach-at91/Makefile
 +++ b/arch/arm/mach-at91/Makefile
-@@ -56,6 +56,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
+@@ -58,6 +58,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
  obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
- obj-$(CONFIG_MACH_USB_A9263)  += board-usb-a9263.o
+ obj-$(CONFIG_MACH_USB_A9263)  += board-usb-a926x.o
  obj-$(CONFIG_MACH_NEOCORE926) += board-neocore926.o
 +obj-$(CONFIG_MACH_TQMA9263)   += board-tqma9263.o
  
old mode 100755 (executable)
new mode 100644 (file)
index e3d6ffd..df8e50a
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-at91/at91sam9260_devices.c
 +++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -571,7 +571,7 @@ static struct platform_device at91sam926
+@@ -579,7 +579,7 @@ static struct platform_device at91sam926
        .num_resources  = ARRAY_SIZE(spi1_resources),
  };
  
index 3216969a7d3cc6fd2206ad8ded818da480bf7bba..2b67be1e4eab75fca50b19b03c588c11c9428933 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.37.6/arch/arm/mach-at91/board-flexibity.c
-===================================================================
---- linux-2.6.37.6.orig/arch/arm/mach-at91/board-flexibity.c   2011-05-07 10:07:03.112684983 +0100
-+++ linux-2.6.37.6/arch/arm/mach-at91/board-flexibity.c        2011-05-07 10:07:33.480684982 +0100
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
 @@ -1,7 +1,7 @@
  /*
   * linux/arch/arm/mach-at91/board-flexibity.c
@@ -11,8 +9,8 @@ Index: linux-2.6.37.6/arch/arm/mach-at91/board-flexibity.c
   *  Copyright (C) 2005 SAN People
   *  Copyright (C) 2006 Atmel
   *
-@@ -65,6 +65,13 @@
-       .pullup_pin     = 0,            /* pull-up driven by UDC */
+@@ -62,6 +62,13 @@ static struct at91_udc_data __initdata f
+       .pullup_pin     = -EINVAL,              /* pull-up driven by UDC */
  };
  
 +/* I2C devices */
@@ -25,7 +23,7 @@ Index: linux-2.6.37.6/arch/arm/mach-at91/board-flexibity.c
  /* SPI devices */
  static struct spi_board_info flexibity_spi_devices[] = {
        {       /* DataFlash chip */
-@@ -143,6 +150,9 @@
+@@ -141,6 +148,9 @@ static void __init flexibity_board_init(
        at91_add_device_usbh(&flexibity_usbh_data);
        /* USB Device */
        at91_add_device_udc(&flexibity_udc_data);
index de7a8dca3dbe47f7033c17e4cc809c07a35964ae..59f9bb30ee1d3cd3cb82ae99b8d745b15714da32 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.39/arch/arm/mach-at91/board-flexibity.c
-===================================================================
---- linux-2.6.39.orig/arch/arm/mach-at91/board-flexibity.c     2011-06-17 11:02:11.335016002 +0100
-+++ linux-2.6.39/arch/arm/mach-at91/board-flexibity.c  2011-06-17 11:02:20.395016002 +0100
-@@ -96,49 +96,49 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -94,49 +94,49 @@ static struct gpio_led flexibity_leds[]
                .name                   = "usb1:green",
                .gpio                   = AT91_PIN_PA12,
                .active_low             = 1,
index da146dcd868339ac89b720e26709367d120fbaaf..ecb23f3d9c514334cd2989fcc175262757a9a866 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 44b04d38a7d954f5217774418f3dd54186a28ec1..5cb57bc3b3f6d000d29c11ab7866799a8a4769eb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 4a7d351b644883921bf93036aec29d2def6ba59d..d4fa69d2390572d6bbb22804db3149a30d386ff8 100644 (file)
@@ -10,7 +10,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -894,3 +896,5 @@ static void __devinit quirk_usb_early_ha
+@@ -898,3 +900,5 @@ static void __devinit quirk_usb_early_ha
        pci_disable_device(pdev);
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
index e0b7c6c799bb2a6608328f687ef12a4697a97d8a..34da1d40a024aed2b6b0f77261de15f819aea4f1 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index ff91d601004c3e0cc59dbf27ef9df85d885c7fcd..b5ff5cec9eb9f03077d446c34002fef0ca81775c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 88a55a4c22278cfc0da1abc145be09163120bee7..3c3bc09f6aa68698059fa7a663f64145d83318e5 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 3630c78f161fbb56997b26a30aa7ef2e6fbd6e96..9c2c3a0435123d7e08bdf128c6a34854cf547c5e 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index f516785b065f2a7544416fcb4e9a7d41d60cf595..fd9f42ca259d659e5f9814804b917d7d40d67aec 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 
 include $(INCLUDE_DIR)/target.mk
 
index f4aba9bd7a702cac5a624f115cd6334e6ec3274c..f2b6547d58c839870fdc9c441c3dff777e9e3967 100644 (file)
@@ -3,7 +3,7 @@ or as a module
 
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -98,7 +98,7 @@ config ZLIB_INFLATE
+@@ -108,7 +108,7 @@ config ZLIB_INFLATE
        tristate
  
  config ZLIB_DEFLATE
index 17e326698555c11a22fbea5a18ea6d907fc359e7..5ff7aa018b7cf5326d00c99f5a710cf24c197f5b 100644 (file)
@@ -1,4 +1,4 @@
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
 BOARDNAME:=Traverse Geos
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
 DEFAULT_PACKAGES += \