ppp: fix building pptp plugin
authorJo-Philipp Wich <jo@mein.io>
Tue, 17 Jul 2018 18:21:39 +0000 (20:21 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 17 Jul 2018 19:21:44 +0000 (21:21 +0200)
The pptp.so plugin needs to be built with -fPIC as well in order to be
linkable again.

Fixes 888a15ff83 ("ppp: add missing -fPIC to rp-pppoe.so CFLAGS")
Fixes e7397eef69 ("ppp: compile with LTO enabled")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/ppp/Makefile
package/network/services/ppp/patches/511-pptp_cflags.patch [new file with mode: 0644]

index 60c07565f3bd1749f086e940c5d9ffe545c107e3..9fbee90f12de3fdf9bd25fd31261fe0f3220dd2c 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.7
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.7
-PKG_RELEASE:=12
+PKG_RELEASE:=13
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.samba.org/pub/ppp/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.samba.org/pub/ppp/
diff --git a/package/network/services/ppp/patches/511-pptp_cflags.patch b/package/network/services/ppp/patches/511-pptp_cflags.patch
new file mode 100644 (file)
index 0000000..548bf41
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/pppd/plugins/pptp/Makefile.linux
++++ b/pppd/plugins/pptp/Makefile.linux
+@@ -20,7 +20,7 @@ all: pptp.so
+       $(CC) $(CFLAGS) -c -o $@ $<
+ pptp.so: dirutil.o orckit_quirks.o pptp.o pptp_callmgr.o pptp_ctrl.o pptp_quirks.o util.o vector.o
+-      $(CC) -o pptp.so -shared dirutil.o orckit_quirks.o pptp.o pptp_callmgr.o pptp_ctrl.o pptp_quirks.o util.o vector.o
++      $(CC) -fPIC -o pptp.so -shared dirutil.o orckit_quirks.o pptp.o pptp_callmgr.o pptp_ctrl.o pptp_quirks.o util.o vector.o
+ install: all
+       $(INSTALL) -d -m 755 $(LIBDIR)