uboot-sunxi: add support for Olimex A64-Olinuxino eMMC
authorPetr Štetiar <ynezz@true.cz>
Mon, 16 Mar 2020 14:37:54 +0000 (15:37 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sat, 28 Mar 2020 12:03:02 +0000 (13:03 +0100)
Adding U-Boot image for Olimex A64-Olinuxino eMMC, including patch which
adds eMMC boot partition configuration commands.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/260-configs-a64-olinuxino-emmc-add-eMMC-boot-part-config.patch [new file with mode: 0644]

index f4e58e52b50ffcca8d27f6887f64d5e12dcc8c6d..e7823e6f05d66c0835a3bac875f0241654553cf4 100644 (file)
@@ -33,6 +33,14 @@ define U-Boot/a64-olinuxino
   UENV:=a64
 endef
 
+define U-Boot/a64-olinuxino-emmc
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=Olimex A64-OLinuXino eMMC
+  BUILD_DEVICES:=olimex_a64-olinuxino-emmc
+  DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino-emmc:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 define U-Boot/A10-OLinuXino-Lime
   BUILD_SUBTARGET:=cortexa8
   NAME:=A10 OLinuXino LIME
@@ -269,6 +277,7 @@ endef
 
 UBOOT_TARGETS := \
        a64-olinuxino \
+       a64-olinuxino-emmc \
        A10-OLinuXino-Lime \
        A13-OLinuXino \
        A20-OLinuXino-Lime \
diff --git a/package/boot/uboot-sunxi/patches/260-configs-a64-olinuxino-emmc-add-eMMC-boot-part-config.patch b/package/boot/uboot-sunxi/patches/260-configs-a64-olinuxino-emmc-add-eMMC-boot-part-config.patch
new file mode 100644 (file)
index 0000000..a448b83
--- /dev/null
@@ -0,0 +1,29 @@
+From 7fa26c287b225c5e42be6d1a81d45592ec45bd9c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Wed, 18 Mar 2020 12:59:01 +0100
+Subject: [PATCH] configs: a64-olinuxino-emmc: add eMMC boot part config
+ commands
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+mmc bootbus and partconf commands are needed in order to be able to
+configure booting from separate boot0/boot1 eMMC partitions.
+
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ configs/a64-olinuxino-emmc_defconfig | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configs/a64-olinuxino-emmc_defconfig b/configs/a64-olinuxino-emmc_defconfig
+index 8443a6dae9e3..9a96a964b1dc 100644
+--- a/configs/a64-olinuxino-emmc_defconfig
++++ b/configs/a64-olinuxino-emmc_defconfig
+@@ -12,6 +12,7 @@ CONFIG_USE_PREBOOT=y
+ CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-olinuxino-emmc"
+ CONFIG_SYS_RELOC_GD_ENV_ADDR=y
+ CONFIG_SUN8I_EMAC=y
++CONFIG_SUPPORT_EMMC_BOOT=y
+ CONFIG_USB_EHCI_HCD=y
+ CONFIG_USB_OHCI_HCD=y
+ CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y