openssl: fix upstream regression for non-ec builds
authorSteven Barth <cyrus@openwrt.org>
Mon, 9 Feb 2015 15:26:35 +0000 (15:26 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 9 Feb 2015 15:26:35 +0000 (15:26 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 44364

package/libs/openssl/Makefile
package/libs/openssl/patches/220-fix-no-ec-build.patch [new file with mode: 0644]

index 7a21e51c5fdb8b2ceedc56450eabb6de1a8f9924..42165a733ca858ba035cac708bb2130986825879 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_VERSION:=1.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_BUILD_PARALLEL:=1
diff --git a/package/libs/openssl/patches/220-fix-no-ec-build.patch b/package/libs/openssl/patches/220-fix-no-ec-build.patch
new file mode 100644 (file)
index 0000000..44ec50e
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/ssl/t1_lib.c
++++ b/ssl/t1_lib.c
+@@ -113,9 +113,11 @@
+ #include <openssl/objects.h>
+ #include <openssl/evp.h>
+ #include <openssl/hmac.h>
++#ifndef OPENSSL_NO_EC
+ #ifdef OPENSSL_NO_EC2M
+ # include <openssl/ec.h>
+ #endif
++#endif
+ #include <openssl/ocsp.h>
+ #include <openssl/rand.h>
+ #include "ssl_locl.h"