build: scan.mk: consider KernelPackage pattern as well
authorJo-Philipp Wich <jo@mein.io>
Tue, 10 Jan 2017 15:25:10 +0000 (16:25 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 10 Jan 2017 15:26:55 +0000 (16:26 +0100)
The removal of the ".+Package" pattern in scan.mk also caused the build
system to skip over Makefiles defining only kmods. Adjust the grep pattern
to consider packages with "call KernelPackage" signatures as well.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/scan.mk

index 9b361f8b3b3b4b9c3e64b08e98a7a1d2c24515ca..3a884fb5f5fffcbf9af43bcab0db8e0762a80c2d 100644 (file)
@@ -51,7 +51,7 @@ $(OVERRIDELIST):
 ifeq ($(SCAN_NAME),target)
   GREP_STRING=BuildTarget
 else
 ifeq ($(SCAN_NAME),target)
   GREP_STRING=BuildTarget
 else
-  GREP_STRING=(Build/DefaultTargets|BuildPackage)
+  GREP_STRING=(Build/DefaultTargets|BuildPackage|KernelPackage)
 endif
 
 $(FILELIST): $(OVERRIDELIST)
 endif
 
 $(FILELIST): $(OVERRIDELIST)