mxs: remove obsolete kernel package depending on linux 3.18
authorFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 09:14:49 +0000 (10:14 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 11:10:20 +0000 (12:10 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/mxs/modules.mk

index d3633605772194392e1a679b9ac58063efbe4edc..147c25d1e760abf257c1ce0d7422232504e7cdef 100644 (file)
@@ -33,27 +33,6 @@ endef
 
 $(eval $(call KernelPackage,wdt-stmp3xxx))
 
 
 $(eval $(call KernelPackage,wdt-stmp3xxx))
 
-define KernelPackage/sound-soc-mxs
-  TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
-  KCONFIG:= \
-       CONFIG_SND_SOC_MXS_BUILTIN_CODEC \
-       CONFIG_SND_MXS_SOC_BUILTIN
-  FILES:= \
-       $(LINUX_DIR)/sound/soc/mxs/snd-soc-mxs-builtin-audio.ko \
-       $(LINUX_DIR)/sound/soc/mxs/snd-soc-mxs-builtin-dai.ko \
-       $(LINUX_DIR)/sound/soc/mxs/snd-soc-mxs-builtin-pcm.ko \
-       $(LINUX_DIR)/sound/soc/codecs/snd-soc-mxs-builtin-codec.ko
-  AUTOLOAD:=$(call AutoLoad,65,snd-soc-mxs-builtin-pcm snd-soc-mxs-builtin-dai snd-soc-mxs-builtin-codec snd-soc-mxs-builtin-audio)
-  DEPENDS:=@TARGET_mxs +kmod-sound-soc-core @LINUX_3_18
-  $(call AddDepends/sound)
-endef
-
-define KernelPackage/sound-soc-mxs/description
-  Kernel support for Freescale i.MX23/i.MX28 built-in SoC audio
-endef
-
-$(eval $(call KernelPackage,sound-soc-mxs))
-
 define KernelPackage/iio-mxs-lradc
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Freescale i.MX23/28 LRADC driver
 define KernelPackage/iio-mxs-lradc
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Freescale i.MX23/28 LRADC driver