make the AP83 and VSC7385 SPI drivers available on 2.6.2[89]
authorGabor Juhos <juhosg@openwrt.org>
Sat, 6 Jun 2009 04:43:55 +0000 (04:43 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 6 Jun 2009 04:43:55 +0000 (04:43 +0000)
SVN-Revision: 16351

target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/config-2.6.29
target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch [new file with mode: 0644]

index 2fcd9ccddb4e57e2d3c706338f9731b9d765afd7..6148e60d260fd8caa38acd44bdf072cc84f30074 100644 (file)
@@ -177,11 +177,13 @@ CONFIG_SERIAL_8250_RUNTIME_UARTS=1
 # CONFIG_SLAB is not set
 CONFIG_SLUB=y
 CONFIG_SPI=y
+CONFIG_SPI_AP83=y
 CONFIG_SPI_AR71XX=y
 CONFIG_SPI_BITBANG=y
 CONFIG_SPI_GPIO=y
 CONFIG_SPI_MASTER=y
 # CONFIG_SPI_SPIDEV is not set
+# CONFIG_SPI_VSC7385 is not set
 CONFIG_SYS_HAS_CPU_MIPS32_R1=y
 CONFIG_SYS_HAS_CPU_MIPS32_R2=y
 CONFIG_SYS_HAS_EARLY_PRINTK=y
index 7acfbb826c57e66c606417cff26bac9681a5b84c..59265aa69bed922d2341c3623723a1ef7af7f554 100644 (file)
@@ -182,11 +182,13 @@ CONFIG_SERIAL_8250_RUNTIME_UARTS=1
 # CONFIG_SLAB is not set
 CONFIG_SLUB=y
 CONFIG_SPI=y
+CONFIG_SPI_AP83=y
 CONFIG_SPI_AR71XX=y
 CONFIG_SPI_BITBANG=y
 CONFIG_SPI_GPIO=y
 CONFIG_SPI_MASTER=y
 # CONFIG_SPI_SPIDEV is not set
+# CONFIG_SPI_VSC7385 is not set
 CONFIG_SYS_HAS_CPU_MIPS32_R1=y
 CONFIG_SYS_HAS_CPU_MIPS32_R2=y
 CONFIG_SYS_HAS_EARLY_PRINTK=y
diff --git a/target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch
new file mode 100644 (file)
index 0000000..a8e889a
--- /dev/null
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER)              += spi.o
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83)                        += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX)              += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL)                       += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN)                        += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+ comment "SPI Master Controller Drivers"
++config SPI_AP83
++      tristate "Atheros AP83 specific SPI Controller"
++      depends on SPI_MASTER && AR71XX_MACH_AP83
++      select SPI_BITBANG
++      help
++        This is a specific SPI controller driver for the Atheros AP83
++        reference board.
++
+ config SPI_AR71XX
+       tristate "Atheros AR71xx SPI Controller"
+       depends on SPI_MASTER && ATHEROS_AR71XX
diff --git a/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
new file mode 100644 (file)
index 0000000..26f6156
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -283,6 +283,11 @@ config SPI_TLE62X0
+         sysfs interface, with each line presented as a kind of GPIO
+         exposing both switch control and diagnostic feedback.
++config SPI_VSC7385
++      tristate "Vitesse VSC7385 ethernet switch driver"
++      help
++        SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_SPI_SH_SCI)             += spi_sh_sci.
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_AT25)                += at25.o
+ obj-$(CONFIG_SPI_SPIDEV)      += spidev.o
++obj-$(CONFIG_SPI_VSC7385)     += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0)     += tle62x0.o
+ #     ... add above this line ...
diff --git a/target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch
new file mode 100644 (file)
index 0000000..a8e889a
--- /dev/null
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER)              += spi.o
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83)                        += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX)              += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL)                       += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN)                        += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+ comment "SPI Master Controller Drivers"
++config SPI_AP83
++      tristate "Atheros AP83 specific SPI Controller"
++      depends on SPI_MASTER && AR71XX_MACH_AP83
++      select SPI_BITBANG
++      help
++        This is a specific SPI controller driver for the Atheros AP83
++        reference board.
++
+ config SPI_AR71XX
+       tristate "Atheros AR71xx SPI Controller"
+       depends on SPI_MASTER && ATHEROS_AR71XX
diff --git a/target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch
new file mode 100644 (file)
index 0000000..b071d5d
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -272,6 +272,11 @@ config SPI_TLE62X0
+         sysfs interface, with each line presented as a kind of GPIO
+         exposing both switch control and diagnostic feedback.
++config SPI_VSC7385
++      tristate "Vitesse VSC7385 ethernet switch driver"
++      help
++        SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SPI_SH_SCI)             += spi_sh_sci.
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV)      += spidev.o
++obj-$(CONFIG_SPI_VSC7385)     += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0)     += tle62x0.o
+ #     ... add above this line ...