uboot-envtools: add ipq806x support
authorJohn Crispin <john@phrozen.org>
Tue, 7 Jun 2016 17:19:01 +0000 (19:19 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 13 Jun 2016 20:51:41 +0000 (22:51 +0200)
Signed-off-by: Adrian Panella <ianchi74@outlook.com>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ipq [new file with mode: 0755]
target/linux/ipq806x/Makefile

index a5b0f923101e6378903829a98f65364666f76435..fd41005aac70bea0e6c649ee5088a25c9dd04821 100644 (file)
@@ -85,6 +85,10 @@ ifneq ($(CONFIG_TARGET_imx6),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/imx6 $(1)/etc/uci-defaults/30_uboot-envtools
 endif
+ifneq ($(CONFIG_TARGET_ipq806x),)
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DATA) ./files/ipq $(1)/etc/uci-defaults/30_uboot-envtools
+endif
 ifneq ($(CONFIG_TARGET_kirkwood),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/kirkwood $(1)/etc/uci-defaults/30_uboot-envtools
diff --git a/package/boot/uboot-envtools/files/ipq b/package/boot/uboot-envtools/files/ipq
new file mode 100755 (executable)
index 0000000..8cf0ddb
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# Copyright (C) 2016 LEDE
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/ipq806x.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+board=$(ipq806x_board_name)
+
+
+case "$board" in
+"ea8500")
+       ubootenv_add_uci_config "/dev/mtd10" "0x0" "0x20000" "0x20000"
+       ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0
index 50e9467c5d973a58be04e9ff46e1467b8cae984a..a4d2bff59e6bd3fa016ecdf2c5a3aa84e3f816ef 100644 (file)
@@ -20,6 +20,7 @@ DEFAULT_PACKAGES += \
        kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
        kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
        kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
-       kmod-ath10k ath10k-firmware-qca99x0 wpad-mini
+       kmod-ath10k ath10k-firmware-qca99x0 wpad-mini \
+       uboot-envtools
 
 $(eval $(call BuildTarget))