tools: Improve diffability/maintainability
authorOlliver Schinagl <oliver@schinagl.nl>
Tue, 17 Jan 2023 19:54:05 +0000 (20:54 +0100)
committerOlliver Schinagl <oliver@schinagl.nl>
Tue, 17 Jan 2023 19:54:05 +0000 (20:54 +0100)
Like with commit ae614fb397c2 ("tools: Improve diffability/maintainability")
we also want tools-core to be easy to maintain. While a smaller target,
it's still usefull and makes things nice and consistent.

To avoid duplicating any tools in the comment, simplify the comment
instead.

Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
tools/Makefile

index a8044dcf1fe3253b215492d1681b8e1d092fa52a..7ca874aa91d696139da2e791f093796df2fc827e 100644 (file)
@@ -147,8 +147,10 @@ $(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(
 
 $(foreach tool, $(filter-out xz,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/xz/compile))
 
-# make any tool depend on tar, xz and patch to ensure that archives can be unpacked and patched properly
-tools-core := tar xz patch
+# make any tool depend on the following to ensure that archives can be unpacked and patched properly
+tools-core += patch
+tools-core += tar
+tools-core += xz
 
 $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(curdir)/%/compile,$(tools-core))))
 tools-y += $(tools-core)