download: create immutable subversion checkout archive
authorTomasz Maciej Nowak <tmn505@gmail.com>
Wed, 10 May 2023 17:07:07 +0000 (19:07 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 18 May 2023 14:17:52 +0000 (16:17 +0200)
On each generation of the archive check sum will differ, because when
checking out subversion repository, current date is used for directories
creation. Force tar to assign creation date of the last revision for all
items inside archive.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
include/download.mk

index 34d31653b1a4d8600ac00ae1ad33546502149e1c..9ab0b6c08fca7b737b62f7db9ad817b438b8b66e 100644 (file)
@@ -187,7 +187,7 @@ define DownloadMethod/svn
                svn export --non-interactive --trust-server-cert -r$(VERSION) $(URL) $(SUBDIR) || \
                svn export --non-interactive -r$(VERSION) $(URL) $(SUBDIR) ) && \
                echo "Packing checkout..." && \
-               export TAR_TIMESTAMP="" && \
+               export TAR_TIMESTAMP="`svn info -r$(VERSION) --show-item last-changed-date $(URL)`" && \
                $(call dl_tar_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
                mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/ && \
                rm -rf $(SUBDIR); \