kernel: mark kmod-udptunnel as hiddden to replace the NET_UDP_TUNNEL kconfig hack
authorFelix Fietkau <nbd@nbd.name>
Thu, 4 Aug 2016 17:19:17 +0000 (19:19 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 4 Aug 2016 18:53:02 +0000 (20:53 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/netsupport.mk
target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch [deleted file]
target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch [deleted file]
target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch [deleted file]

index 2d574751e586843faeec92d8cb253f05dcc6fc50..cf1de6a8941e8c668b4995ea5f2fbb0f7a6bc144 100644 (file)
@@ -149,6 +149,7 @@ define KernelPackage/udptunnel4
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 UDP tunneling support
   KCONFIG:=CONFIG_NET_UDP_TUNNEL
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 UDP tunneling support
   KCONFIG:=CONFIG_NET_UDP_TUNNEL
+  HIDDEN:=1
   FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
 endef
   FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
 endef
@@ -161,6 +162,7 @@ define KernelPackage/udptunnel6
   TITLE:=IPv6 UDP tunneling support
   DEPENDS:=@IPV6
   KCONFIG:=CONFIG_NET_UDP_TUNNEL
   TITLE:=IPv6 UDP tunneling support
   DEPENDS:=@IPV6
   KCONFIG:=CONFIG_NET_UDP_TUNNEL
+  HIDDEN:=1
   FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
 endef
   FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
 endef
diff --git a/target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch b/target/linux/generic/patches-3.18/263-udp_tunnel_kconfig_hack.patch
deleted file mode 100644 (file)
index e8fb296..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -308,7 +308,7 @@ config NET_IPVTI
-         on top.
- config NET_UDP_TUNNEL
--      tristate
-+      tristate "IP: UDP tunnel"
-       select NET_IP_TUNNEL
-       default n
diff --git a/target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch b/target/linux/generic/patches-4.1/263-udp_tunnel_kconfig_hack.patch
deleted file mode 100644 (file)
index e8fb296..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -308,7 +308,7 @@ config NET_IPVTI
-         on top.
- config NET_UDP_TUNNEL
--      tristate
-+      tristate "IP: UDP tunnel"
-       select NET_IP_TUNNEL
-       default n
diff --git a/target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch b/target/linux/generic/patches-4.4/263-udp_tunnel_kconfig_hack.patch
deleted file mode 100644 (file)
index e8fb296..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -308,7 +308,7 @@ config NET_IPVTI
-         on top.
- config NET_UDP_TUNNEL
--      tristate
-+      tristate "IP: UDP tunnel"
-       select NET_IP_TUNNEL
-       default n