ath79: add support for Archer C58/C59 v1
authorDavid Bauer <mail@david-bauer.net>
Wed, 31 Oct 2018 19:19:49 +0000 (20:19 +0100)
committerJohn Crispin <john@phrozen.org>
Mon, 26 Nov 2018 11:05:45 +0000 (12:05 +0100)
This commit adds support for the Archer C58 v1 and C59 v1, previously
supported in the ar71xx target.

CPU:   Qualcomm QCA9561
RAM:   64M (C58) / 128M (C59)
FLASH: 8M (C58) / 16M (C59)
WiFi:  QCA9561 bgn 3x3:3
       QCA9888 nac 2x2:2
LED:   Power, WiFi 2.4, WiFi 5, WAN green, WAN amber, LAN, WPS
       Only C59: USB
BTN:   WPS, WiFi, Reset

Installation
------------

Via Web-UI:
Update factory image via Web-UI.

Via TFTP:
Rename factory image to "tp_recovery.bin" and place it in the root-dir
of your tftp server. Configure to listen on 192.168.0.66. Power up the
router while holding down the reset-button. The router will flash itself
and reboot.

Note: For TFTP, you might need a switch between router and computer, as
link establishment might take to long.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi [new file with mode: 0644]
target/linux/ath79/image/common-tp-link.mk
target/linux/ath79/image/generic-tp-link.mk

index 47c900f6eb843a2665dc99d60ccad3044014a1e5..7945ecba1f080718e2be318e53d9c98212b63bd3 100755 (executable)
@@ -52,6 +52,11 @@ pcs,cr3000)
        ucidef_set_led_switch "lan3" "LAN3" "pcs:blue:lan3" "switch0" "0x10"
        ucidef_set_led_switch "lan4" "LAN4" "pcs:blue:lan4" "switch0" "0x02"
        ;;
        ucidef_set_led_switch "lan3" "LAN3" "pcs:blue:lan3" "switch0" "0x10"
        ucidef_set_led_switch "lan4" "LAN4" "pcs:blue:lan4" "switch0" "0x02"
        ;;
+tplink,archer-c58-v1|\
+tplink,archer-c59-v1)
+       ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
+       ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth0"
+       ;;
 tplink,re450-v2)
        ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
        ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
 tplink,re450-v2)
        ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
        ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
index fca9e42fb53c0c2b26fcc6d0de7ae921897c7d4d..6aca7c789900ed273a52435274460df53d65a525 100755 (executable)
@@ -32,7 +32,9 @@ ath79_setup_interfaces()
        wd,mynet-wifi-rangeextender)
                ucidef_set_interface_lan "eth0"
                ;;
        wd,mynet-wifi-rangeextender)
                ucidef_set_interface_lan "eth0"
                ;;
-       avm,fritz4020)
+       avm,fritz4020|\
+       tplink,archer-c58-v1|\
+       tplink,archer-c59-v1)
                ucidef_set_interface_wan "eth0"
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:1" "2:lan:4" "3:lan:3" "4:lan:2"
                ucidef_set_interface_wan "eth0"
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:1" "2:lan:4" "3:lan:3" "4:lan:2"
index b4bc20d1cfeb42f4d2681b7d85d12b8631f71ae4..cbc5c961707a7dde459c1841236976c8a001d060 100644 (file)
@@ -131,6 +131,12 @@ case "$FIRMWARE" in
                ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
                        /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
                ;;
                ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
                        /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
                ;;
+       tplink,archer-c58-v1|\
+       tplink,archer-c59-v1)
+               ath10kcal_extract "art" 20480 12064
+               ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
+                       /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
+               ;;
        esac
        ;;
 *)
        esac
        ;;
 *)
index 59c58f9c6747bbc9acbf2c9c1a491b2c6e840b28..fe5aa64a1915e6a7483954a9b13c84d653811299 100644 (file)
@@ -18,6 +18,10 @@ case "$board" in
                [ "$PHYNBR" -eq 1 ] && \
                        echo $(k2t_get_mac "lan_mac") > /sys${DEVPATH}/macaddress
                ;;
                [ "$PHYNBR" -eq 1 ] && \
                        echo $(k2t_get_mac "lan_mac") > /sys${DEVPATH}/macaddress
                ;;
+       tplink,archer-c58-v1|\
+       tplink,archer-c59-v1)
+               echo $(macaddr_add $(mtd_get_mac_binary mac 8)  $(($PHYNBR - 1)) ) > /sys${DEVPATH}/macaddress
+               ;;
        *)
                ;;
 esac
        *)
                ;;
 esac
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts
new file mode 100644 (file)
index 0000000..ffce955
--- /dev/null
@@ -0,0 +1,130 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9561_tplink_archer-c5x.dtsi"
+
+/ {
+       compatible = "tplink,archer-c58-v1", "qca,qca9560";
+       model = "TP-LINK Archer C58 v1";
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &power;
+               led-running = &power;
+               led-upgrade = &power;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power: power {
+                       label = "tp-link:green:power";
+                       gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wlan2g {
+                       label = "tp-link:green:wlan2g";
+                       gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+                       default-state = "off";
+               };
+
+               wlan5g {
+                       label = "tp-link:green:wlan5g";
+                       gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+                       default-state = "off";
+               };
+
+               wan_green {
+                       label = "tp-link:green:wan";
+                       gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               wan_amber {
+                       label = "tp-link:amber:wan";
+                       gpios = <&led_gpio 5 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               wps {
+                       label = "tp-link:green:wps";
+                       gpios = <&led_gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x010000>;
+                               read-only;
+                       };
+
+                       mac: partition@10000 {
+                               label = "mac";
+                               reg = <0x010000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x020000 0x7c0000>;
+                       };
+
+                       partition@7e0000 {
+                               label = "tplink";
+                               reg = <0x7e0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+       mtd-mac-address = <&mac 0x8>;
+       mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+       status = "okay";
+       mtd-mac-address = <&mac 0x8>;
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&mac 0x8>;
+};
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts
new file mode 100644 (file)
index 0000000..9d4df9a
--- /dev/null
@@ -0,0 +1,153 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9561_tplink_archer-c5x.dtsi"
+
+/ {
+       compatible = "tplink,archer-c59-v1", "qca,qca9560";
+       model = "TP-LINK Archer C59 v1";
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &power;
+               led-running = &power;
+               led-upgrade = &power;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power: power {
+                       label = "tp-link:green:power";
+                       gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wlan2g {
+                       label = "tp-link:green:wlan2g";
+                       gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+                       default-state = "off";
+               };
+
+               wlan5g {
+                       label = "tp-link:green:wlan5g";
+                       gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+                       default-state = "off";
+               };
+
+               wan_green {
+                       label = "tp-link:green:wan";
+                       gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               wan_amber {
+                       label = "tp-link:amber:wan";
+                       gpios = <&led_gpio 5 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               wps {
+                       label = "tp-link:green:wps";
+                       gpios = <&led_gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               usb {
+                       label = "tp-link:green:usb";
+                       gpios = <&led_gpio 7 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "usbport";
+                       trigger-sources = <&hub_port>;
+               };
+       };
+};
+
+&usb0 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x010000>;
+                               read-only;
+                       };
+
+                       mac: partition@10000 {
+                               label = "mac";
+                               reg = <0x010000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x020000 0xe30000>;
+                       };
+
+                       partition@e50000 {
+                               label = "tplink";
+                               reg = <0xe50000 0x1a0000>;
+                               read-only;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+       mtd-mac-address = <&mac 0x8>;
+       mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+       status = "okay";
+       mtd-mac-address = <&mac 0x8>;
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&mac 0x8>;
+};
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi b/target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi
new file mode 100644 (file)
index 0000000..dc56bf6
--- /dev/null
@@ -0,0 +1,98 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       compatible = "tplink,archer-c5x", "qca,qca9560";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       led_spi {
+               compatible = "spi-gpio";
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               gpio-sck = <&gpio 18 GPIO_ACTIVE_HIGH>;
+               gpio-mosi = <&gpio 17 GPIO_ACTIVE_HIGH>;
+               cs-gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
+               num-chipselects = <1>;
+
+               led_gpio: led_gpio@0 {
+                       compatible = "fairchild,74hc595";
+                       reg = <0>;
+                       gpio-controller;
+                       #gpio-cells = <2>;
+                       registers-number = <1>;
+                       spi-max-frequency = <10000000>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <100>;
+
+               wps_button {
+                       label = "WPS button";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi_button {
+                       label = "WiFi button";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+
+               reset_button {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+
+               gpio_shift_register_oe {
+                       gpio-export,name = "tp-link:oe:sr";
+                       gpio-export,output = <0>;
+                       gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+               };
+
+               gpio_shift_register_reset {
+                       gpio-export,name = "tp-link:reset:sr";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 19 GPIO_ACTIVE_HIGH>;
+               };
+
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+};
+
+&eth0 {
+       phy-mode = "mii";
+       phy-handle = <&swphy0>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <1>;
+               switch-phy-swap = <1>;
+       };
+};
index 7490aeb1f3b82ca87c64b6c779d5b80ac0d2a95b..1dd36ef52593cb859c8fbce8fa5c49e5f82e21f7 100644 (file)
@@ -39,6 +39,14 @@ define Build/mktplinkfw-combined
        @mv $@.new $@
 endef
 
        @mv $@.new $@
 endef
 
+define Build/uImageArcher
+       mkimage -A $(LINUX_KARCH) \
+               -O linux -T kernel \
+               -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+       @mv $@.new $@
+endef
+
 define Device/tplink
   TPLINK_HWREV := 0x1
   TPLINK_HEADER_VERSION := 1
 define Device/tplink
   TPLINK_HWREV := 0x1
   TPLINK_HEADER_VERSION := 1
@@ -88,3 +96,15 @@ define Device/tplink-16mlzma
   TPLINK_FLASHLAYOUT := 16Mlzma
   IMAGE_SIZE := 15872k
 endef
   TPLINK_FLASHLAYOUT := 16Mlzma
   IMAGE_SIZE := 15872k
 endef
+
+define Device/tplink-safeloader
+  $(Device/tplink)
+  KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header
+  IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata
+  IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+
+define Device/tplink-safeloader-uimage
+  $(Device/tplink-safeloader)
+  KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
+endef
index d65e29e72ac9da86d44f8a25cd844ef197e15ba4..c89198621e5f666935ef7099b2075664543a6a52 100644 (file)
@@ -1,5 +1,27 @@
 include ./common-tp-link.mk
 
 include ./common-tp-link.mk
 
+define Device/tplink_archer-c58-v1
+  $(Device/tplink-safeloader-uimage)
+  ATH_SOC := qca9561
+  IMAGE_SIZE := 7936k
+  DEVICE_TITLE := TP-LINK Archer C58 v1
+  TPLINK_BOARD_ID := ARCHER-C58-V1
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  SUPPORTED_DEVICES += archer-c58-v1
+endef
+TARGET_DEVICES += tplink_archer-c58-v1
+
+define Device/tplink_archer-c59-v1
+  $(Device/tplink-safeloader-uimage)
+  ATH_SOC := qca9561
+  IMAGE_SIZE := 14528k
+  DEVICE_TITLE := TP-LINK Archer C59 v1
+  TPLINK_BOARD_ID := ARCHER-C59-V1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  SUPPORTED_DEVICES += archer-c59-v1
+endef
+TARGET_DEVICES += tplink_archer-c59-v1
+
 define Device/tplink_archer-c7-v1
   $(Device/tplink-8mlzma)
   ATH_SOC := qca9558
 define Device/tplink_archer-c7-v1
   $(Device/tplink-8mlzma)
   ATH_SOC := qca9558