toolchain/gcc: use STAGING_DIR_HOST instead of hardcoding default
authorChristian Marangi <ansuelsmth@gmail.com>
Fri, 2 Dec 2022 19:31:38 +0000 (20:31 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 9 Jan 2023 20:33:19 +0000 (21:33 +0100)
Use STAGING_DIR_HOST to reference staging host directory instead of
hardcoding it to default path.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
toolchain/gcc/common.mk
toolchain/gcc/final/Makefile

index ea2e2634b69ddf69b1ab7255b562f7ca962be2ae..7eae855eea42c7ba1d4a2166cf615b0ddcc0d8a1 100644 (file)
@@ -72,7 +72,7 @@ ifdef CONFIG_INSTALL_GCCGO
 endif
 
 ifdef CONFIG_GCC_USE_GRAPHITE
-  GRAPHITE_CONFIGURE:= --with-isl=$(TOPDIR)/staging_dir/host
+  GRAPHITE_CONFIGURE:= --with-isl=$(STAGING_DIR_HOST)
 else
   GRAPHITE_CONFIGURE:= --without-isl --without-cloog
 endif
@@ -106,9 +106,9 @@ GCC_CONFIGURE:= \
                        --with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
                $(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
                $(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
-               --with-gmp=$(TOPDIR)/staging_dir/host \
-               --with-mpfr=$(TOPDIR)/staging_dir/host \
-               --with-mpc=$(TOPDIR)/staging_dir/host \
+               --with-gmp=$(STAGING_DIR_HOST) \
+               --with-mpfr=$(STAGING_DIR_HOST) \
+               --with-mpc=$(STAGING_DIR_HOST) \
                --disable-decimal-float \
                --with-diagnostics-color=auto-if-env \
                --enable-__cxa_atexit \
index 0315b9d1f163b9d61c48929360763a82b7263602..049ddf61f03355281d8fb34087c48e3418d43cb1 100644 (file)
@@ -9,7 +9,7 @@ GCC_CONFIGURE += \
        --enable-threads \
        --with-slibdir=$(TOOLCHAIN_DIR)/lib \
        --enable-lto \
-       --with-libelf=$(TOPDIR)/staging_dir/host
+       --with-libelf=$(STAGING_DIR_HOST)
 
 ifndef CONFIG_USE_GLIBC
   GCC_CONFIGURE += --disable-libsanitizer