brcm2708: Add wifi driver, firmware and NVRAM for RPi1
authorDaniel Golle <daniel@makrotopia.org>
Wed, 20 Jun 2018 09:16:54 +0000 (11:16 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 20 Jun 2018 09:19:26 +0000 (11:19 +0200)
Apparently there are RPi1 devices with BRCM43430 wifi, such as the
Pi Zero W. Add the necessary packages for that to the image generated
for those boards as well.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/brcm2708/image/Makefile

index 69c1d83fbfe9e82d9786067eff7616e568c6185e..456570cdec9b685178bec15f99a4e52d4de10b9e 100644 (file)
@@ -57,6 +57,7 @@ define Device/rpi
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
   SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-mini
 endef
 ifeq ($(SUBTARGET),bcm2708)
   TARGET_DEVICES += rpi