ralink: add support for wrtnode
authorJohn Crispin <john@openwrt.org>
Fri, 7 Mar 2014 09:54:59 +0000 (09:54 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 7 Mar 2014 09:54:59 +0000 (09:54 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 39786

target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WRTNODE.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 703471838df7b8ea2ff057301307b96ddc550df6..1cbf7bf0224dd193b633e9edde7e5e04aa165d8c 100755 (executable)
@@ -96,6 +96,7 @@ ramips_setup_interfaces()
        f5d8235-v2 | \
        hg255d | \
        rt-n14u | \
+       wrtnode | \
        ur-326n4g)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
index 5a686e671989f8ba1493a64aaa1f119d285f67a1..a3a26cb23ec3020925805af052a72e1178e794ae 100755 (executable)
@@ -280,6 +280,9 @@ ramips_board_detect() {
        *"V22SG")
                name="v22sg"
                ;;
+       *"WRTNODE")
+               name="wrtnode"
+               ;;
        *"Sercomm NA930")
                name="na930"
                ;;
index 8bc2abd15677e697fb1db64e3872f13948af6405..8ff6063f197851be6c533c2f86baad965f6cb79c 100755 (executable)
@@ -84,6 +84,8 @@ platform_check_image() {
        ur-326n4g |\
        ur-336un |\
        wr512-3gn |\
+       wmr300 |\
+       wrtnode |\
        x5 |\
        x8)
                [ "$magic" != "27051956" ] && {
diff --git a/target/linux/ramips/dts/WRTNODE.dts b/target/linux/ramips/dts/WRTNODE.dts
new file mode 100644 (file)
index 0000000..33d7c91
--- /dev/null
@@ -0,0 +1,76 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "wrtnode", "ralink,mt7620n-soc";
+       model = "WRTNode";
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l12805d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "wllll";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               ralink,group = "ephy", "wled", "pa", "i2c", "wdt", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+};
index ae95b686555b42dae74137f5a53e20395e049caf..c6a42ad8e76f9ddb43b7566239b8885183ccb43d 100644 (file)
@@ -690,11 +690,13 @@ endif
 
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
+Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
 
 ifeq ($(SUBTARGET),mt7620n)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/WMR300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
+       $(call Image/Build/Profile/WRTNODE,$(1))
 endef
 endif