wolfssl: bump to 5.4.0
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Fri, 15 Jul 2022 19:09:58 +0000 (16:09 -0300)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 16 Jul 2022 20:22:40 +0000 (22:22 +0200)
This version fixes two vulnerabilities:
-CVE-2022-34293[high]: Potential for DTLS DoS attack
-[medium]: Ciphertext side channel attack on ECC and DH operations.

The patch fixing x86 aesni build has been merged upstream.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/libs/wolfssl/Makefile
package/libs/wolfssl/patches/100-disable-hardening-check.patch
package/libs/wolfssl/patches/200-ecc-rng.patch
package/libs/wolfssl/patches/300-AESNI-fix-configure-to-use-minimal-compiler-flags.patch [deleted file]

index a511837800f759c69433092201637ea3d203d7eb..55928f1446874779d8a0063c3362ff2bcd0a2711 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wolfssl
-PKG_VERSION:=5.3.0-stable
+PKG_VERSION:=5.4.0-stable
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
-PKG_HASH:=1a3bb310dc01d3e73d9ad91b6ea8249d081016f8eef4ae8f21d3421f91ef1de9
+PKG_HASH:=dc36cc19dad197253e5c2ecaa490c7eef579ad448706e55d73d79396e814098b
 
 PKG_FIXUP:=libtool libtool-abiver
 PKG_INSTALL:=1
index 7e473b390bb2c7dadb3f46b84e1fc0bfdcc18d66..d3ad2e27bc3e359cd45f9e3d1df419db98f807c4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/wolfssl/wolfcrypt/settings.h
 +++ b/wolfssl/wolfcrypt/settings.h
-@@ -2338,7 +2338,7 @@ extern void uITRON4_free(void *p) ;
+@@ -2442,7 +2442,7 @@ extern void uITRON4_free(void *p) ;
  #endif
  
  /* warning for not using harden build options (default with ./configure) */
index f1f156a8aeace5a93ba54ae6fec800d0678c7bef..2e09e6d273e39ea8c313442953f9dd1ef5b85bd3 100644 (file)
@@ -11,7 +11,7 @@ RNG regardless of the built settings for wolfssl.
 
 --- a/wolfcrypt/src/ecc.c
 +++ b/wolfcrypt/src/ecc.c
-@@ -11655,21 +11655,21 @@ void wc_ecc_fp_free(void)
+@@ -12288,21 +12288,21 @@ void wc_ecc_fp_free(void)
  
  #endif /* FP_ECC */
  
diff --git a/package/libs/wolfssl/patches/300-AESNI-fix-configure-to-use-minimal-compiler-flags.patch b/package/libs/wolfssl/patches/300-AESNI-fix-configure-to-use-minimal-compiler-flags.patch
deleted file mode 100644 (file)
index d65a117..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From 9ba77300f9f5dea9f53aed00bf6c33d10b7b2fce Mon Sep 17 00:00:00 2001
-From: Sean Parkinson <sean@wolfssl.com>
-Date: Thu, 7 Jul 2022 09:30:48 +1000
-Subject: [PATCH] AESNI: fix configure to use minimal compiler flags
-
-
-diff --git a/configure.ac b/configure.ac
-index df97ac75c..6abb0c744 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2142,21 +2142,19 @@ then
-     if test "$ENABLED_AESNI" = "yes" || test "$ENABLED_INTELASM" = "yes"
-     then
-         AM_CFLAGS="$AM_CFLAGS -DWOLFSSL_AESNI"
--        if test "$GCC" = "yes"
-+        if test "$CC" != "icc"
-         then
--            # clang needs these flags
--            if test "$CC" = "clang"
--            then
--                AM_CFLAGS="$AM_CFLAGS -maes -mpclmul"
--            else
--                # GCC needs these flags, icc doesn't
--                # opt levels greater than 2 may cause problems on systems w/o
--                # aesni
--                if test "$CC" != "icc"
--                then
--                    AM_CFLAGS="$AM_CFLAGS -maes -msse4 -mpclmul"
--                fi
--            fi
-+            case $host_os in
-+            mingw*)
-+                # Windows uses intrinsics for GCM which uses SSE4 instructions.
-+                # MSVC has own build files.
-+                AM_CFLAGS="$AM_CFLAGS -maes -msse4 -mpclmul"
-+                ;;
-+            *)
-+                # Intrinsics used in AES_set_decrypt_key (TODO: rework)
-+                AM_CFLAGS="$AM_CFLAGS -maes"
-+                ;;
-+            esac
-         fi
-         AS_IF([test "x$ENABLED_AESGCM" != "xno"],[AM_CCASFLAGS="$AM_CCASFLAGS -DHAVE_AESGCM"])
-     fi