ramips: mmc: Add SD card support to HC5661A
authorLoveSy <shana@zju.edu.cn>
Mon, 28 May 2018 01:47:19 +0000 (09:47 +0800)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 08:43:37 +0000 (10:43 +0200)
Tested on HC5661A and it now fixes the issue that when enabling sd card
in HC5661A, the wan and 3 lan ports will down.

Known issue:
- When enabling SD card support, the led light of system will down and the rest 2 lights keep working.

Signed-off-by: LoveSy <shana@zju.edu.cn>
target/linux/ramips/dts/HC5661A.dts
target/linux/ramips/image/mt76x8.mk

index 57b86cf0693a77ed6f581eb22c35c6612058c8c6..5931906a8c74c6b1cb642d7be3f33be017b2f45c 100644 (file)
                reg = <0x0 0x8000000>;
        };
 
+       sdhci@10130000 {
+               status = "okay";
+       };
+
        gpio-leds {
                compatible = "gpio-leds";
 
index 729bf830039d6bc89ef08eb8b31661b891506f0a..143944176dd2f272ac6915a3bca51b787ff6bed3 100644 (file)
@@ -54,6 +54,7 @@ define Device/hc5661a
   DTS := HC5661A
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   DEVICE_TITLE := HiWiFi HC5661A
+  DEVICE_PACKAGES := kmod-sdhci-mt7620
 endef
 TARGET_DEVICES += hc5661a