kernel: add package for Epson RX-8025 and compatible I2C RTC
authorMathew McBride <matt@traverse.com.au>
Thu, 3 Oct 2019 06:34:51 +0000 (16:34 +1000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 19 Oct 2019 10:49:11 +0000 (12:49 +0200)
RX-8025 is an I2C RTC from Epson, some newer products such as the
RX-8035 are also compatible.

Signed-off-by: Mathew McBride <matt@traverse.com.au>
package/kernel/linux/modules/other.mk

index 276a8f09acd68cc45535df00885a75c9a4a241db..0ffaac20140266d81cde0e55fed96d9e315328f0 100644 (file)
@@ -650,6 +650,23 @@ endef
 
 $(eval $(call KernelPackage,rtc-rs5c372a))
 
 
 $(eval $(call KernelPackage,rtc-rs5c372a))
 
+define KernelPackage/rtc-rx8025
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Epson RX-8025 / RX-8035
+  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  DEPENDS:=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_RX8025 \
+       CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-rx8025.ko
+  AUTOLOAD:=$(call AutoLoad,50,rtc-rx8025,1)
+endef
+
+define KernelPackage/rtc-rx8025/description
+ Kernel module for Epson RX-8025 and RX-8035 I2C RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-rx8025))
+
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)