copy the initramfs kernel to bin/ on x86-2.6 (fixes #1359)
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 Mar 2007 17:12:23 +0000 (17:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 Mar 2007 17:12:23 +0000 (17:12 +0000)
SVN-Revision: 6463

target/linux/x86-2.6/image/Makefile

index e59446472ec2d9a39b551477c16f953822f6fd86..9c26d6851ceb69efde33375cf5d976c1c0d90626 100644 (file)
@@ -75,6 +75,10 @@ define Image/Build/squashfs
     $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
+define Image/BuildKernel
+       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+endef
+
 define Image/Build
        $(call Image/Build/$(1))
        $(call Image/Build/grub,$(1))