ar71xx: Add support for PISEN TS-D084
authorChuanhong Guo <gch981213@gmail.com>
Sun, 22 Apr 2018 10:29:36 +0000 (18:29 +0800)
committerJohn Crispin <john@phrozen.org>
Thu, 24 May 2018 15:24:31 +0000 (17:24 +0200)
PISEN TS-D084 is an wireless router with a battery and integrated power supply based on Atheros AR9331.

Specification:

- 400/400/200 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR2)
- 8 MB of FLASH (SPI NOR)
- 1x 10/100 Mbps Ethernet
- 1T1R 2.4 GHz (AR9331)
- 1x USB 2.0

Flash instruction:
The manufacturer are using exactly the same firmware header as TP-LINK TL-WR703N (including device ID!). Simply upload the factory firmware into WebUI and flashing is done.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
(cherry picked from commit a789c0f49159c618d990541c23e00630f7296ebc)

target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-ts-d084.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic.mk

index 5898261b3d4091077ca76b35d45a378ea1b259e4..547e2e04d2d136c4a0df868aefa303b87963a1e2 100755 (executable)
@@ -139,6 +139,7 @@ ar71xx_setup_interfaces()
        tl-wr802n-v1|\
        tl-wr802n-v2|\
        tl-wr902ac-v1|\
        tl-wr802n-v1|\
        tl-wr802n-v2|\
        tl-wr902ac-v1|\
+       ts-d084|\
        tube2h|\
        unifi|\
        unifiac-lite|\
        tube2h|\
        unifi|\
        unifiac-lite|\
index 19dd4c2a13ea5c6f865fcad069aa4be439741afb..03c639a2b7a7e29f86d5a1891735fc465006b30c 100644 (file)
@@ -208,6 +208,7 @@ get_status_led() {
                ;;
        e600g-v2|\
        oolite-v5.2-dev|\
                ;;
        e600g-v2|\
        oolite-v5.2-dev|\
+       ts-d084|\
        wifi-pineapple-nano)
                status_led="$board:blue:system"
                ;;
        wifi-pineapple-nano)
                status_led="$board:blue:system"
                ;;
index 42bd80d9ad8cb97da890ec3c6fd611ae04ea2c47..0fe778d9ff869dd8563533db4649eac2f997c8aa 100755 (executable)
@@ -1325,6 +1325,9 @@ ar71xx_board_detect() {
        *"TL-WR942N v1")
                name="tl-wr942n-v1"
                ;;
        *"TL-WR942N v1")
                name="tl-wr942n-v1"
                ;;
+       *"TS-D084")
+               name="ts-d084"
+               ;;
        *"Tube2H")
                name="tube2h"
                ;;
        *"Tube2H")
                name="tube2h"
                ;;
index 284582fa2b88770124309f9c825bd461b0db6748..eae7382af7d206568fdf3918d0a9621deb53946a 100755 (executable)
@@ -483,6 +483,7 @@ platform_check_image() {
        tl-wr941nd|\
        tl-wr941nd-v5|\
        tl-wr941nd-v6|\
        tl-wr941nd|\
        tl-wr941nd-v5|\
        tl-wr941nd-v6|\
+       ts-d084|\
        wifi-pineapple-nano)
                local magic_ver="0100"
 
        wifi-pineapple-nano)
                local magic_ver="0100"
 
index 35efd1710bec58ede218e9e39daeb1b8838f78d4..94858ddbbaf17e71d2d4eb64ad1779d4a7a9697e 100644 (file)
@@ -233,6 +233,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_TL_WR941ND is not set
 # CONFIG_ATH79_MACH_TL_WR941ND_V6 is not set
 # CONFIG_ATH79_MACH_TL_WR942N_V1 is not set
 # CONFIG_ATH79_MACH_TL_WR941ND is not set
 # CONFIG_ATH79_MACH_TL_WR941ND_V6 is not set
 # CONFIG_ATH79_MACH_TL_WR942N_V1 is not set
+# CONFIG_ATH79_MACH_TS_D084 is not set
 # CONFIG_ATH79_MACH_TUBE2H is not set
 # CONFIG_ATH79_MACH_UBNT is not set
 # CONFIG_ATH79_MACH_UBNT_UNIFIAC is not set
 # CONFIG_ATH79_MACH_TUBE2H is not set
 # CONFIG_ATH79_MACH_UBNT is not set
 # CONFIG_ATH79_MACH_UBNT_UNIFIAC is not set
index 40d33b53fa921d6e16e7f9d0284be8129ad017ba..74da7418e29d02c916652a95b2eef134a4b31cb7 100644 (file)
@@ -1997,6 +1997,16 @@ config ATH79_MACH_TL_WR2543N
        select ATH79_DEV_M25P80
        select ATH79_DEV_USB
 
        select ATH79_DEV_M25P80
        select ATH79_DEV_USB
 
+config ATH79_MACH_TS_D084
+       bool "PISEN TS-D084 support"
+       select SOC_AR933X
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        select SOC_AR913X
 config ATH79_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        select SOC_AR913X
index 2124ab70c957749f368c50499053e50603728c0a..898853e5c09b8647040ca2badeecb7500385b99d 100644 (file)
@@ -243,6 +243,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR941ND)         += mach-tl-wr941nd.o
 obj-$(CONFIG_ATH79_MACH_TL_WR941ND_V6)         += mach-tl-wr941nd-v6.o
 obj-$(CONFIG_ATH79_MACH_TL_WR940N_V4)          += mach-tl-wr940n-v4.o
 obj-$(CONFIG_ATH79_MACH_TL_WR942N_V1)          += mach-tl-wr942n-v1.o
 obj-$(CONFIG_ATH79_MACH_TL_WR941ND_V6)         += mach-tl-wr941nd-v6.o
 obj-$(CONFIG_ATH79_MACH_TL_WR940N_V4)          += mach-tl-wr940n-v4.o
 obj-$(CONFIG_ATH79_MACH_TL_WR942N_V1)          += mach-tl-wr942n-v1.o
+obj-$(CONFIG_ATH79_MACH_TS_D084)               += mach-ts-d084.o
 obj-$(CONFIG_ATH79_MACH_TUBE2H)                        += mach-tube2h.o
 obj-$(CONFIG_ATH79_MACH_UBNT)                  += mach-ubnt.o
 obj-$(CONFIG_ATH79_MACH_UBNT_UNIFIAC)          += mach-ubnt-unifiac.o
 obj-$(CONFIG_ATH79_MACH_TUBE2H)                        += mach-tube2h.o
 obj-$(CONFIG_ATH79_MACH_UBNT)                  += mach-ubnt.o
 obj-$(CONFIG_ATH79_MACH_UBNT_UNIFIAC)          += mach-ubnt-unifiac.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ts-d084.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ts-d084.c
new file mode 100644 (file)
index 0000000..38786fd
--- /dev/null
@@ -0,0 +1,86 @@
+/*
+ *  PISEN TS-D084 board support
+ *  Based on TP-LINK TL-WR703N/TL-MR10U board support
+ *
+ *  Copyright (C) 2011 dongyuqi <729650915@qq.com>
+ *  Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TS_D084_GPIO_LED_SYSTEM        0
+#define TS_D084_GPIO_BTN_RESET 12
+
+
+#define TS_D084_KEYS_POLL_INTERVAL     20      /* msecs */
+#define TS_D084_KEYS_DEBOUNCE_INTERVAL (3 * TS_D084_KEYS_POLL_INTERVAL)
+
+static const char *ts_d084_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data ts_d084_flash_data = {
+       .part_probes    = ts_d084_part_probes,
+};
+
+static struct gpio_led ts_d084_leds_gpio[] __initdata = {
+       {
+               .name           = "ts-d084:blue:system",
+               .gpio           = TS_D084_GPIO_LED_SYSTEM,
+               .active_low     = 0,
+       },
+};
+
+static struct gpio_keys_button ts_d084_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TS_D084_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TS_D084_GPIO_BTN_RESET,
+               .active_low     = 0,
+       }
+};
+
+static void __init ts_d084_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_register_m25p80(&ts_d084_flash_data);
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(ts_d084_leds_gpio),
+                                ts_d084_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, TS_D084_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(ts_d084_gpio_keys),
+                                       ts_d084_gpio_keys);
+
+       ath79_register_usb();
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+
+       ath79_register_mdio(0, 0x0);
+       ath79_register_eth(0);
+
+       ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_TS_D084, "TS-D084", "PISEN TS-D084",
+            ts_d084_setup);
index 3d5bcfbab4488fc90737d4cc5b889aa57b96f2c6..0d0d309ce87373464ac5bed4bc49307dc3908849 100644 (file)
@@ -302,6 +302,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WR940N_V4,                /* TP-LINK TL-WR940N v4 */
        ATH79_MACH_TL_WR940N_V6,                /* TP-LINK TL-WR940N v6 */
        ATH79_MACH_TL_WR942N_V1,                /* TP-LINK TL-WR942N v1 */
        ATH79_MACH_TL_WR940N_V4,                /* TP-LINK TL-WR940N v4 */
        ATH79_MACH_TL_WR940N_V6,                /* TP-LINK TL-WR940N v6 */
        ATH79_MACH_TL_WR942N_V1,                /* TP-LINK TL-WR942N v1 */
+       ATH79_MACH_TS_D084,                     /* PISEN TS-D084 */
        ATH79_MACH_TUBE2H,                      /* Alfa Network Tube2H */
        ATH79_MACH_UBNT_AIRGW,                  /* Ubiquiti AirGateway */
        ATH79_MACH_UBNT_AIRGWP,                 /* Ubiquiti AirGateway Pro */
        ATH79_MACH_TUBE2H,                      /* Alfa Network Tube2H */
        ATH79_MACH_UBNT_AIRGW,                  /* Ubiquiti AirGateway */
        ATH79_MACH_UBNT_AIRGWP,                 /* Ubiquiti AirGateway Pro */
index 3f93d6e61ec961cee9e11c537061e5862c951346..c85453af9378fd01c4d794bcb704d2d1a3ea988a 100644 (file)
@@ -166,6 +166,7 @@ CONFIG_ATH79_MACH_TL_WR841N_V8=y
 CONFIG_ATH79_MACH_TL_WR841N_V9=y
 CONFIG_ATH79_MACH_TL_WR902AC_V1=y
 CONFIG_ATH79_MACH_TL_WR942N_V1=y
 CONFIG_ATH79_MACH_TL_WR841N_V9=y
 CONFIG_ATH79_MACH_TL_WR902AC_V1=y
 CONFIG_ATH79_MACH_TL_WR942N_V1=y
+CONFIG_ATH79_MACH_TS_D084=y
 CONFIG_ATH79_MACH_TUBE2H=y
 CONFIG_ATH79_MACH_UBNT=y
 CONFIG_ATH79_MACH_UBNT_UNIFIAC=y
 CONFIG_ATH79_MACH_TUBE2H=y
 CONFIG_ATH79_MACH_UBNT=y
 CONFIG_ATH79_MACH_UBNT_UNIFIAC=y
index 020e01f85a08b5fe858845bd4a6085b3f8ebb647..bceeba0009e366357e4f7ab3e3858dc310fc4f02 100644 (file)
@@ -998,6 +998,17 @@ define Device/tellstick-znet-lite
 endef
 TARGET_DEVICES += tellstick-znet-lite
 
 endef
 TARGET_DEVICES += tellstick-znet-lite
 
+define Device/ts-d084
+  $(Device/tplink-8mlzma)
+  DEVICE_TITLE := PISEN TS-D084
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+  BOARDNAME := TS-D084
+  DEVICE_PROFILE := TSD084
+  TPLINK_HWID := 0x07030101
+  CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += ts-d084
+
 define Device/n5q
   DEVICE_TITLE := ALFA Network N5Q
   DEVICE_PACKAGES := rssileds -swconfig
 define Device/n5q
   DEVICE_TITLE := ALFA Network N5Q
   DEVICE_PACKAGES := rssileds -swconfig