ipq40xx: add support for GL.iNet GL-A1300
authorWeiping Yang <weiping.yang@gl-inet.com>
Mon, 19 Sep 2022 09:47:40 +0000 (05:47 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 9 Nov 2022 22:34:37 +0000 (23:34 +0100)
Specifications:
SOC: Qualcomm IPQ4018 (DAKOTA) ARM Quad-Core
RAM: 256 MiB
FLASH1: 4 MiB NOR
FLASH2: 128 MiB NAND
ETH: Qualcomm QCA8075
WLAN1: Qualcomm Atheros QCA4018 2.4GHz 802.11b/g/n 2x2
WLAN2: Qualcomm Atheros QCA4018 5G 802.11n/ac W2 2x2
USB: 1 x USB 3.0 port
Button: 1 x Reset button
Switch: 1 x Mode switch
LED: 1 x Blue LED + 1 x White LED

Install via uboot tftp or uboot web failsafe.

By uboot tftp:
(IPQ40xx) # tftpboot 0x84000000 openwrt-ipq40xx-generic-glinet_gl-a1300-squashfs-nand-factory.ubi
(IPQ40xx) # nand erase 0 0x8000000
(IPQ40xx) # nand write 0x84000000 0 $filesize

By uboot web failsafe:
Push the reset button for 10 seconds util the power led flash faster,
then use broswer to access http://192.168.1.1

Afterwards upgrade can use sysupgrade image.

Signed-off-by: Weiping Yang <weiping.yang@gl-inet.com>
package/boot/uboot-envtools/files/ipq40xx
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-glinet_gl-a1300.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-gl-a1300.dts [new file with mode: 0644]
target/linux/ipq40xx/image/generic.mk

index 823a33ca1b113de5ee74204a03e373e82ac70640..4ee83bb05703c3707d58cfd58282c242e8d8f394 100644 (file)
@@ -34,6 +34,7 @@ case "$board" in
 alfa-network,ap120c-ac|\
 devolo,magic-2-wifi-next|\
 edgecore,ecw5211|\
+glinet,gl-a1300 |\
 glinet,gl-ap1300|\
 glinet,gl-b1300|\
 glinet,gl-b2200|\
index da82e16dde16590015994207a5162890bcd490be..2096b5f2d6be32e3b6786c822a7306fdd68b258e 100644 (file)
@@ -30,6 +30,7 @@ ALLWIFIBOARDS:= \
        edgecore_ecw5410 \
        edgecore_oap100 \
        extreme-networks_ws-ap3915i \
+       glinet_gl-a1300 \
        glinet_gl-ap1300 \
        glinet_gl-s1300 \
        linksys_ea8300 \
@@ -105,6 +106,7 @@ $(eval $(call generate-ipq-wifi-package,devolo_magic-2-wifi-next,devolo Magic 2
 $(eval $(call generate-ipq-wifi-package,edgecore_ecw5410,Edgecore ECW5410))
 $(eval $(call generate-ipq-wifi-package,edgecore_oap100,Edgecore OAP100))
 $(eval $(call generate-ipq-wifi-package,extreme-networks_ws-ap3915i,Edgecore OAP100))
+$(eval $(call generate-ipq-wifi-package,glinet_gl-a1300,GL.iNet GL-A1300))
 $(eval $(call generate-ipq-wifi-package,glinet_gl-ap1300,GL.iNet GL-AP1300))
 $(eval $(call generate-ipq-wifi-package,glinet_gl-s1300,GL.iNet GL-S1300))
 $(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
diff --git a/package/firmware/ipq-wifi/board-glinet_gl-a1300.qca4019 b/package/firmware/ipq-wifi/board-glinet_gl-a1300.qca4019
new file mode 100644 (file)
index 0000000..d8695c9
Binary files /dev/null and b/package/firmware/ipq-wifi/board-glinet_gl-a1300.qca4019 differ
index 2aef8d65ddbdce312ae99fd700bebd38925d03fe..16b0f05a5b0d37d3b1c165957ca400303b4abc20 100644 (file)
@@ -58,6 +58,7 @@ ipq40xx_setup_interfaces()
        compex,wpj428)
                ucidef_set_interface_lan "lan1 lan2"
                ;;
+       glinet,gl-a1300|\
        glinet,gl-b1300|\
        mobipromo,cm520-79f)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
index 668ae04414420d69221144173ff9a3b69c92d615..6b8f62d73586abff417b4a75be47102aee58e5f9 100644 (file)
@@ -111,6 +111,7 @@ platform_do_upgrade() {
        edgecore,ecw5211 |\
        edgecore,oap100 |\
        engenius,eap2200 |\
+       glinet,gl-a1300 |\
        glinet,gl-ap1300 |\
        luma,wrtq-329acn |\
        mobipromo,cm520-79f |\
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-gl-a1300.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-gl-a1300.dts
new file mode 100644 (file)
index 0000000..5993243
--- /dev/null
@@ -0,0 +1,326 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "GL.iNet GL-A1300";
+       compatible = "glinet,gl-a1300", "qcom,ipq4019";
+
+       aliases {
+               led-boot = &led_run;
+               led-failsafe = &led_run;
+               led-running = &led_run;
+               led-upgrade = &led_run;
+               label-mac-device = &swport4;
+       };
+
+       chosen {
+               bootargs-append = " ubi.mtd=ubi root=/dev/ubiblock0_1";
+       };
+
+       soc {
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               switch {
+                       label = "switch-button";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_SETUP>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_run: blue {
+                       label = "blue:status";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
+               };
+
+               white {
+                       label = "white:status";
+                       gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+
+               usb {
+                       gpio-export,name = "usb_power";
+                       gpio-export,output = <1>;
+                       gpios = <&tlmm 4 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&prng {
+       status = "okay";
+};
+
+&mdio {
+       status = "okay";
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&crypto {
+       status = "okay";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>, <&tlmm 5 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+
+                       partition@c0000 {
+                               label = "CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+
+                       partition@d0000 {
+                               label = "DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+
+                       partition@e0000 {
+                               label = "APPSBLENV"; /* uboot env*/
+                               reg = <0x000e0000 0x00010000>;
+                       };
+
+                       partition@f0000 {
+                               label = "APPSBL"; /* uboot */
+                               reg = <0x000f0000 0x00080000>;
+                               read-only;
+                       };
+
+                       partition@170000 {
+                               label = "ART";
+                               reg = <0x00170000 0x00010000>;
+                               read-only;
+                               compatible = "nvmem-cells";
+
+                               precal_art_1000: precal@1000 {
+                                       reg = <0x1000 0x2f20>;
+                               };
+
+                               precal_art_5000: precal@5000 {
+                                       reg = <0x5000 0x2f20>;
+                               };
+
+                               macaddr_gmac0: macaddr@0 {
+                                       reg = <0x0 0x6>;
+                               };
+
+                               macaddr_gmac1: macaddr@6 {
+                                       reg = <0x6 0x6>;
+                               };
+                       };
+
+                       partition@180000 {
+                                label = "log";
+                                reg = <0x00180000 0x00020000>;
+                        };
+               };
+       };
+
+       spi-nand@1 {
+               compatible = "spi-nand";
+               reg = <1>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "ubi";
+                               reg = <0x00000000 0x08000000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       i2c_0_pins: i2c_0_pinmux {
+               pinmux {
+                       pins = "gpio58", "gpio59";
+                       function = "blsp_i2c0";
+                       bias-disable;
+               };
+       };
+
+       spi0_pins: spi0_pinmux {
+               mux_spi {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               mux_cs {
+                       function = "gpio";
+                       pins = "gpio54", "gpio5";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&blsp1_i2c3 {
+        status = "okay";
+        pinctrl-0 = <&i2c_0_pins>;
+        pinctrl-names = "default";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport3 {
+       status = "okay";
+
+       label = "lan2";
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac0>;
+       mac-address-increment = <2>;
+};
+
+&swport4 {
+       status = "okay";
+
+       label = "lan1";
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac0>;
+};
+
+&swport5 {
+       status = "okay";
+
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac1>;
+};
+
+&wifi0 {
+       status = "okay";
+       nvmem-cell-names = "pre-calibration";
+       nvmem-cells = <&precal_art_1000>;
+       qcom,ath10k-calibration-variant = "GL-A1300";
+};
+
+&wifi1 {
+       status = "okay";
+       nvmem-cell-names = "pre-calibration";
+       nvmem-cells = <&precal_art_5000>;
+       qcom,ath10k-calibration-variant = "GL-A1300";
+};
index e8e6e29e72792fe8f72c92d8657a1bda5fb89053..b50d072bec34b6c382dce1a5013ba8960e18f6e3 100644 (file)
@@ -565,6 +565,20 @@ endef
 # Missing DSA Setup
 #TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
 
+define Device/glinet_gl-a1300
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := GL.iNet
+       DEVICE_MODEL := GL-A1300
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       IMAGE_SIZE := 131072k
+       DEVICE_PACKAGE := ipq-wifi-glinet_gl-a1300
+endef
+TARGET_DEVICES += glinet_gl-a1300
+
 define Device/glinet_gl-ap1300
        $(call Device/FitImage)
        $(call Device/UbiFit)