ar71xx: Add usb drivers in Archer C7 v4/v5 images
authorDaniel Halmschlager <dh@dev.halms.at>
Tue, 4 Dec 2018 19:40:10 +0000 (20:40 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 5 Dec 2018 21:30:37 +0000 (21:30 +0000)
This commit adds the default usb packages
- kmod-usb-core
- kmod-usb2
- kmod-usb-ledtrig-usbport
for Archer C7 v4 and v5.
(The C7 v5 configuration is based on the v4, therefore the change for v4
also applies for v5.)

Signed-off-by: Daniel Halmschlager <dh@dev.halms.at>
target/linux/ar71xx/image/generic-tp-link.mk

index 08cc444a4947ce0fc089fa42585cc4b608e02fe4..84ae62c383ef409bc0f9a1d36517a85adedf459d 100644 (file)
@@ -139,7 +139,7 @@ TARGET_DEVICES += tl-wdr7500-v3
 define Device/archer-c7-v4
   $(Device/archer-cxx)
   DEVICE_TITLE := TP-LINK Archer C7 v4
-  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
   BOARDNAME := ARCHER-C7-V4
   TPLINK_BOARD_ID := ARCHER-C7-V4
   IMAGE_SIZE := 15104k