rules: fix broken commitcount on alpine system
authorChristian Marangi <ansuelsmth@gmail.com>
Sat, 17 Dec 2022 15:39:00 +0000 (16:39 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 21 Dec 2022 23:14:30 +0000 (00:14 +0100)
To generate commitcount we use grep --max-count. This is not present on
alpine grep and cause wrong generation. Use -m as it's just the short
version of --max-count and more portable.

Fixes: #11200
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit eb7ffeafbfa78235b05abb4ae479376150d7a814)

rules.mk

index c893f61b0f702ba8696a6132567e6f6c1f6ce763..1c6b3abd57e20cf8ec5ec59c144b297f0ee501ca 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -412,7 +412,7 @@ $(shell \
   if git log -1 >/dev/null 2>/dev/null; then \
     if [ -n "$(1)" ]; then \
       last_bump="$$(git log --pretty=format:'%h %s' . | \
-        grep --max-count=1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \
+        grep -1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \
         cut -f 1 -d ' ')"; \
     fi; \
     if [ -n "$$last_bump" ]; then \