wolfssl: enable openssl 1.0.1 compatibility
authorKarl Palsson <karlp@etactica.com>
Mon, 6 Jun 2016 15:49:21 +0000 (15:49 +0000)
committerFelix Fietkau <nbd@nbd.name>
Tue, 7 Jun 2016 07:22:16 +0000 (09:22 +0200)
>From wolfssl/openssl/opensslv.h, and from skimming the contents of what
"--enable-stunnel" actually does, it seems that --enable-opensslextra
doesn't give you the "full" openssl compatibility that you may wish for
these days.  Unfortuantely, while wolfssl writes the build time options
into wolfssl/options.h, it doesn't include that file itself.  User
applications must include that directly.

Signed-off-by: Karl Palsson <karlp@etactica.com>
package/libs/cyassl/Makefile
package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch [deleted file]

index b6440f3a850daeaf467c23f73e95b175e11349e4..a2b3b5eef1ed8ea5d38aca51441fd456fe85147c 100644 (file)
@@ -41,6 +41,7 @@ CONFIGURE_ARGS += \
        --enable-singlethreaded \
        --enable-opensslextra \
        --enable-sni \
+       --enable-stunnel \
        --enable-ecc \
        --disable-examples
 
diff --git a/package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch b/package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch
deleted file mode 100644 (file)
index 51d89f7..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/wolfssl/openssl/ssl.h
-+++ b/wolfssl/openssl/ssl.h
-@@ -402,6 +402,8 @@ typedef WOLFSSL_X509_STORE_CTX X509_STOR
- /* yassl had set the default to be 500 */
- #define SSL_get_default_timeout(ctx) 500
-+#define SSL_set_tlsext_host_name(x, y) wolfSSL_UseSNI(x, WOLFSSL_SNI_HOST_NAME, y, strlen(y))
-+
- /* Lighthttp compatibility */
- #ifdef HAVE_LIGHTY                       
-@@ -488,7 +490,6 @@ typedef WOLFSSL_ASN1_BIT_STRING    ASN1_
- #define SSL_TLSEXT_ERR_NOACK                 alert_warning
- #define TLSEXT_NAMETYPE_host_name            WOLFSSL_SNI_HOST_NAME
--#define SSL_set_tlsext_host_name wolfSSL_set_tlsext_host_name
- #define SSL_get_servername wolfSSL_get_servername
- #define SSL_set_SSL_CTX                  wolfSSL_set_SSL_CTX
- #define SSL_CTX_get_verify_callback      wolfSSL_CTX_get_verify_callback