kernel: update 4.9 to 4.9.12
authorAnsuel Smith <ansuelsmth@gmail.com>
Thu, 23 Feb 2017 17:00:31 +0000 (18:00 +0100)
committerJohn Crispin <john@phrozen.org>
Sun, 26 Feb 2017 07:44:26 +0000 (08:44 +0100)
Refresh generic patch

Compiled and tested WRT1900ACS

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
include/kernel-version.mk
target/linux/generic/patches-4.9/022-net-add-devm-version-of-alloc_etherdev_mqs-function.patch
target/linux/generic/patches-4.9/630-packet_socket_type.patch
target/linux/generic/patches-4.9/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.9/721-phy_packets.patch

index 1dd96821692e9573c666544bb317355b3751f090..d4b9c55ca90bb093d985e6138f729163642fe8dc 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_VERSION-4.4 = .50
-LINUX_VERSION-4.9 = .10
+LINUX_VERSION-4.9 = .12
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
 LINUX_KERNEL_HASH-4.4.50 = e4944ca5bb0bdf63a7e97dc7fbdd38bcc820d8b3b57c4a3a7b3bf9c8a48216b7
-LINUX_KERNEL_HASH-4.9.10 = bd6e05476fd8d9ea4945e11598d87bc97806bbc8d03556abbaaf809707661525
+LINUX_KERNEL_HASH-4.9.12 = fcad54878e98638a2a95d32059ed14a5ef296296d6e408bce6932b80d61b783b
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index faa80ad80518116d58a628739bbcd214e50dc41f..c5d65b7105ef0ecf1ba256901921b735bee5fa1a 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  int eth_gro_complete(struct sk_buff *skb, int nhoff);
 --- a/net/ethernet/eth.c
 +++ b/net/ethernet/eth.c
-@@ -390,6 +390,34 @@ struct net_device *alloc_etherdev_mqs(in
+@@ -391,6 +391,34 @@ struct net_device *alloc_etherdev_mqs(in
  }
  EXPORT_SYMBOL(alloc_etherdev_mqs);
  
index ad2bc356aab8a663683d5d338c77f80997bf6b9f..b40a2d32eb3b7e4b61df24835c635239c467ca03 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3210,6 +3212,7 @@ static int packet_create(struct net *net
+@@ -3211,6 +3213,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3789,6 +3792,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3790,6 +3793,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3841,6 +3854,13 @@ static int packet_getsockopt(struct sock
+@@ -3842,6 +3855,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index b1f7e638b68528c901c2595aeb3bff90db83c727..77ba222e5679967cd682becb52c07d09c7665ad0 100644 (file)
@@ -158,7 +158,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (dev == ip6n->fb_tnl_dev)
                RCU_INIT_POINTER(ip6n->tnls_wc[0], NULL);
        else
-@@ -767,6 +784,107 @@ int ip6_tnl_rcv_ctl(struct ip6_tnl *t,
+@@ -777,6 +794,107 @@ int ip6_tnl_rcv_ctl(struct ip6_tnl *t,
  }
  EXPORT_SYMBOL_GPL(ip6_tnl_rcv_ctl);
  
@@ -266,7 +266,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static int __ip6_tnl_rcv(struct ip6_tnl *tunnel, struct sk_buff *skb,
                         const struct tnl_ptk_info *tpi,
                         struct metadata_dst *tun_dst,
-@@ -819,6 +937,27 @@ static int __ip6_tnl_rcv(struct ip6_tnl
+@@ -829,6 +947,27 @@ static int __ip6_tnl_rcv(struct ip6_tnl
        skb_reset_network_header(skb);
        memset(skb->cb, 0, sizeof(struct inet6_skb_parm));
  
@@ -294,7 +294,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        __skb_tunnel_rx(skb, tunnel->dev, tunnel->net);
  
        err = dscp_ecn_decapsulate(tunnel, ipv6h, skb);
-@@ -948,6 +1087,7 @@ static void init_tel_txopt(struct ipv6_t
+@@ -958,6 +1097,7 @@ static void init_tel_txopt(struct ipv6_t
        opt->ops.opt_nflen = 8;
  }
  
@@ -302,7 +302,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  /**
   * ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
   *   @t: the outgoing tunnel device
-@@ -1271,6 +1411,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1281,6 +1421,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  {
        struct ip6_tnl *t = netdev_priv(dev);
        struct ipv6hdr *ipv6h = ipv6_hdr(skb);
@@ -310,7 +310,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        int encap_limit = -1;
        __u16 offset;
        struct flowi6 fl6;
-@@ -1326,6 +1467,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1336,6 +1477,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
                        fl6.flowi6_mark = skb->mark;
        }
  
@@ -329,7 +329,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (iptunnel_handle_offloads(skb, SKB_GSO_IPXIP6))
                return -1;
  
-@@ -1451,6 +1604,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1461,6 +1614,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
@@ -344,7 +344,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        dst_cache_reset(&t->dst_cache);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1489,6 +1650,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1499,6 +1660,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -352,7 +352,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1866,6 +2028,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1876,6 +2038,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -368,7 +368,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1900,6 +2071,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1910,6 +2081,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_COLLECT_METADATA])
                parms->collect_md = true;
@@ -415,7 +415,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static bool ip6_tnl_netlink_encap_parms(struct nlattr *data[],
-@@ -2009,6 +2220,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -2019,6 +2230,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -428,7 +428,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -2036,6 +2253,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -2046,6 +2263,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(2) +
                /* IFLA_IPTUN_COLLECT_METADATA */
                nla_total_size(0) +
@@ -453,7 +453,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
-@@ -2043,6 +2278,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2053,6 +2288,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -463,7 +463,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
-@@ -2051,9 +2289,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2061,9 +2299,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
@@ -492,7 +492,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (nla_put_u16(skb, IFLA_IPTUN_ENCAP_TYPE, tunnel->encap.type) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_SPORT, tunnel->encap.sport) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_DPORT, tunnel->encap.dport) ||
-@@ -2091,6 +2347,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -2101,6 +2357,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_ENCAP_SPORT]        = { .type = NLA_U16 },
        [IFLA_IPTUN_ENCAP_DPORT]        = { .type = NLA_U16 },
        [IFLA_IPTUN_COLLECT_METADATA]   = { .type = NLA_FLAG },
index 07c7a29ad695a09b1c16b5c56252b86295276f87..90bca022fd721ef32c6357ce9dff19f25721ba0a 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4490,6 +4490,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4485,6 +4485,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
@@ -27,7 +27,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
-@@ -5767,6 +5770,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -5762,6 +5765,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info)
-@@ -5965,6 +6010,8 @@ void netdev_upper_dev_unlink(struct net_
+@@ -5960,6 +6005,8 @@ void netdev_upper_dev_unlink(struct net_
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev, i->ref_nr);
  
@@ -85,7 +85,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6565,6 +6612,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6560,6 +6607,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1746,6 +1746,8 @@ struct net_device {
+@@ -1748,6 +1748,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index 49a9368340343a6f80652441179fe6c125ae3ef5..22ca7df862a80fc42e276a4afc5e9b9c58ce7629 100644 (file)
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1711,6 +1713,11 @@ struct net_device {
+@@ -1712,6 +1714,11 @@ struct net_device {
        const struct ndisc_ops *ndisc_ops;
  #endif
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1777,6 +1784,10 @@ struct net_device {
+@@ -1779,6 +1782,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
@@ -86,7 +86,7 @@
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -2909,10 +2909,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2904,10 +2904,20 @@ static int xmit_one(struct sk_buff *skb,
        if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
                dev_queue_xmit_nit(skb, dev);