kernel: update 3.10 to 3.10.13
authorGabor Juhos <juhosg@openwrt.org>
Fri, 27 Sep 2013 07:19:21 +0000 (07:19 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 27 Sep 2013 07:19:21 +0000 (07:19 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38228

28 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.10/200-MIPS-ath79-fix-ar933x-watchdog-clock.patch [deleted file]
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.10/941-ocf_20120127.patch
target/linux/imx23/Makefile
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.10/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/lantiq/patches-3.10/0032-USB-fix-roothub-for-IFXHCD.patch
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/octeon/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/x86/alix2/target.mk
target/linux/xburst/Makefile
target/linux/xburst/patches-3.10/003-NAND-Add-support-for-subpage-reads-for-NAND_ECC_HW_O.patch

index 52bb309ecfbd2d218d7f62555cba42013dafa6e8..d63ab650a0601fcb9d0e9a0dbb1ba2c13457fde2 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.12)
-  LINUX_KERNEL_MD5SUM:=16e43b3c9957cf5af44863d6809efe38
+ifeq ($(LINUX_VERSION),3.10.13)
+  LINUX_KERNEL_MD5SUM:=64ffe74249442fd7452d12348955ccfd
 endif
 
 # disable the md5sum check for unknown kernel versions
index e80cc5961b6e1980d6da4503de96f6c509e79b55..cabcf04641ca39533432fd2fb556fec94c7ce8f8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ar71xx/patches-3.10/200-MIPS-ath79-fix-ar933x-watchdog-clock.patch b/target/linux/ar71xx/patches-3.10/200-MIPS-ath79-fix-ar933x-watchdog-clock.patch
deleted file mode 100644 (file)
index b3a3cd3..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-From: Felix Fietkau <nbd@openwrt.org>
-Subject: [PATCH] MIPS: ath79: fix ar933x watchdog clock
-
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
---- a/arch/mips/ath79/clock.c
-+++ b/arch/mips/ath79/clock.c
-@@ -164,7 +164,7 @@ static void __init ar933x_clocks_init(vo
-               ath79_ahb_clk.rate = freq / t;
-       }
--      ath79_wdt_clk.rate = ath79_ref_clk.rate;
-+      ath79_wdt_clk.rate = ath79_ahb_clk.rate;
-       ath79_uart_clk.rate = ath79_ref_clk.rate;
- }
index abcff6d3859948558c628afd7235dba2192d5476..a7387e3fd0ab32185ca0454efe3313d42484095b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 60701e502b6e645dbdc04c52e9a9c7ee8239fa1a..c39c0205e5c1113edd97f16fcabc0b2d323ca3d1 100644 (file)
@@ -14,7 +14,7 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 17606f42b4eda75fb6aa1dc26393b82dbd49d33d..0bd3f2fb43f8bf503de9cb1b768dc0ec039791b9 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 535e7033ca26c2f55ec9db02df3f6591f7bede58..3ad04fe9a59dc6bb1883688d688a0413fea8b284 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
index 1fcbc8174fbb0616eb6700aee150032f05cde506..f4aa477b317936c086bd52a14bd47cc5b2cc2dc7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 30066abdb139eb840c32d2aaa53698d643987fca..8568323c90b54a5669c136886fa4a0a75fc59984 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index a177fdeddadff326c582627254397296894c6689..dc16d01ffc4da6d57d5aa13a9aafe7e297ea8610 100644 (file)
  void generate_random_uuid(unsigned char uuid_out[16]);
 --- a/kernel/pid.c
 +++ b/kernel/pid.c
-@@ -422,6 +422,7 @@ void transfer_pid(struct task_struct *ol
+@@ -423,6 +423,7 @@ void transfer_pid(struct task_struct *ol
        new->pids[type].pid = old->pids[type].pid;
        hlist_replace_rcu(&old->pids[type].node, &new->pids[type].node);
  }
index 439b01fc1a0cdd2b30e4255fe0f3a878b6a674fd..fd4ffb24b94e5c2bb20b442a67760bc33cfb47d8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index eed8088460a887cda719a0efb125c0c8a3f0d3c2..621473128fab44c073ebe4679d31f87e48b7ff07 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 7bc839ac49cdb211c6d10c5ba7696464cf42c8f8..86acd347a8035fedfc6fb00dcefa07011eaa849f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index fa9878831875bab76c3da8aeb028f8401cf4531e..9ac2a13b3e85b3825932ab557ed2148966673b6a 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs
 SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 CPU_TYPE:=mips32r2
 
index ce1412aa8668932f95279e8ac000fa4b5fae5bb4..9329e153154431d9b816006f76d519746d30330c 100644 (file)
@@ -5527,7 +5527,7 @@ Subject: [PATCH 01/34] MIPS: lantiq: add pcie driver
                                         unsigned long type);
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -1042,6 +1042,12 @@
+@@ -1044,6 +1044,12 @@
  #define PCI_DEVICE_ID_SGI_LITHIUM     0x1002
  #define PCI_DEVICE_ID_SGI_IOC4                0x100a
  
index 559a6b8c3d696f922aea759e585e8b5eaf668693..22526cfb7c2785bdd1657d7191ac53ec6a4176d9 100644 (file)
@@ -20,7 +20,7 @@ Subject: [PATCH 32/34] USB: fix roothub for IFXHCD
  choice
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4041,7 +4041,7 @@ hub_port_init (struct usb_hub *hub, stru
+@@ -4036,7 +4036,7 @@ hub_port_init (struct usb_hub *hub, stru
                udev->ttport = hdev->ttport;
        } else if (udev->speed != USB_SPEED_HIGH
                        && hdev->speed == USB_SPEED_HIGH) {
index c05a30246fc93244dca51bc4a63d562fc3783f01..853013a41e3ef8a31cb5a04d8f03c9e8f2bc0ae7 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 DEVICE_TYPE:=developerboard
 
index 278cdee34578660f867b2407fcc3ca06fb01895e..bbb9c01a6aadded6eeee8ad2443a926f86815597 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index bf3c5f86a987715bf74a4ea4e0ab8236b92556b3..611cafbb5127425a4eae5e8c25216c7e58ae2049 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index a9fd5abfdea9fbd68b2b88cb1e93b365a548805e..a861ca23b49340c5b1388dda36c81107c9e55191 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
 CPU_CFLAGS_octeon:=-march=octeon
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 947c8ebb22e2a93dfe34ac985c31a420cfe10057..cac70d8959a0dbabedf1e1b79827e97ca62af7ad 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 6c48c019449f2532a94b08eb009a87f30f17dbea..78e840e765f3b4d5a904be22f2cae3c5bc90f448 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a13a2c9a18f571b593a2fed87a72b56d4d64765..fec7ddbc9319ec2a3c3c2e1d2e13a002bbc0e2c9 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x rt3883 mt7620a rt288x
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 1a30bef8f0631fd30c06727be5a69fa131abcdf5..c37123ad47a127446bee70e8cdc2f6cda1a2cc13 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz broken
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 7088bc33e7838ad466d9a10b8e3dda74f361957b..ee5dfc51b84d5c146554262aeb3ad98b3306485f 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 DEVICE_TYPE:=developerboard
 
index fce9c90972633cbcb8ad1e640b0348946db4db99..2d789a1fde5150ce1355d63daa4c12c0e254a532 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 CS5535_MASK:=0x0b000042
 
 CPU_TYPE := geode
index b799b7c70b7cc4f1facdad653180ebb808fa4b4d..0de518b45b7b59654202244eddcf87b7c98589a5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 DEVICE_TYPE=other
 
index 1754de71b6c12f4fb9cd5d7ea5a5938783fa12ab..4d2c88e29d1bbe805cb7e6ca402fbf49faf70598 100644 (file)
@@ -106,7 +106,7 @@ Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>
                        else
                                ret = chip->ecc.read_page(mtd, chip, bufpoi,
                                                          oob_required, page);
-@@ -3475,8 +3544,13 @@ int nand_scan_tail(struct mtd_info *mtd)
+@@ -3477,8 +3546,13 @@ int nand_scan_tail(struct mtd_info *mtd)
                                   "hardware ECC not possible\n");
                        BUG();
                }