dnsmasq: Pass TARGET_CPPFLAGS to Makefile
authorFlorian Fainelli <f.fainelli@gmail.com>
Sat, 16 Sep 2017 23:27:37 +0000 (16:27 -0700)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 15:33:33 +0000 (16:33 +0100)
With the introduction of the ubus notifications, we would now fail building
dnsmasq with external toolchains that don't automatically search for headers.
Pass TARGET_CPPFLAGS to the Makefile to resolve that.

Fixes: 34a206bc1194 ("dnsmasq: add ubus notifications for new leases")
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
(cherry picked from commit ef485bb23d207e0b1031d264a6fafce01d2bdf8f)

package/network/services/dnsmasq/Makefile

index fe6a6d2feddb8af80f577ae6404fdb04b9405ce6..01c7191192bae2ebf23a7fcd7216625be7fd87d4 100644 (file)
@@ -137,7 +137,7 @@ endif
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        COPTS="$(COPTS)" \
        PREFIX="/usr"