binutils: remove linaro version string, it confuses gcc lto support detection
authorFelix Fietkau <nbd@openwrt.org>
Mon, 20 Oct 2014 11:43:08 +0000 (11:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 20 Oct 2014 11:43:08 +0000 (11:43 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43004

toolchain/binutils/Makefile

index b88fbd8b2ca96c04a9f55be085026a4dedaa3fa3..820b5f8efaec6408af7ecdef2de2ed6206c0bf49 100644 (file)
@@ -65,6 +65,7 @@ define Host/Prepare
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
+       $(SED) 's, " Linaro.*,,' $(HOST_BUILD_DIR)/bfd/version.h
 endef
 
 define Host/Configure
 endef
 
 define Host/Configure