linux-firmware: disable stripping
authorRobert Marko <robimarko@gmail.com>
Wed, 28 Dec 2022 21:57:49 +0000 (22:57 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 29 Dec 2022 13:15:55 +0000 (14:15 +0100)
It has been brought to my attention that recently added WCN6855 firmware
is broken as it is getting stripped during building due to being 2 ELF
binaries.
I am sure WCN6750 and any other ELF binaries are having the same issue,
so since stripping firmware binaries is clearly unwanted disable it.

Fixes: b4d3694f81f4 ("linux-firmware: package ath11k consumer cards firmware")
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/firmware/linux-firmware/Makefile

index 70c63f172e859ed1ce0877830000815b2ab0bb2c..7ffd8baf8841239442a701fe4909bc639abc4012 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linux-firmware
 PKG_VERSION:=20221214
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -21,6 +21,9 @@ SCAN_DEPS = *.mk
 
 include $(INCLUDE_DIR)/package.mk
 
+RSTRIP:=:
+STRIP:=:
+
 define Package/firmware-default
   SECTION:=firmware
   CATEGORY:=Firmware