ath79: fix GL.iNet GL-AR300M sysupgrade
authorMathias Kresin <dev@kresin.me>
Thu, 6 Dec 2018 10:53:05 +0000 (11:53 +0100)
committerMathias Kresin <dev@kresin.me>
Thu, 6 Dec 2018 12:28:22 +0000 (13:28 +0100)
The userspace boardname derived from the dts compatible was out of sync
with the expected board added to the image metadata. This way a
sysupgrade is refused.

Sync the userspace boardname and the baordname used in the image metdata
to allow a seamless sasupgrade.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ath79/dts/qca9531_glinet_ar300m-nand.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9531_glinet_ar300m-nor.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9531_glinet_ar300m.dtsi
target/linux/ath79/dts/qca9531_glinet_ar300m_nand.dts [deleted file]
target/linux/ath79/dts/qca9531_glinet_ar300m_nor.dts [deleted file]
target/linux/ath79/image/generic.mk
target/linux/ath79/image/nand.mk

diff --git a/target/linux/ath79/dts/qca9531_glinet_ar300m-nand.dts b/target/linux/ath79/dts/qca9531_glinet_ar300m-nand.dts
new file mode 100644 (file)
index 0000000..82f8418
--- /dev/null
@@ -0,0 +1,68 @@
+/dts-v1/;
+
+#include "qca9531_glinet_ar300m.dtsi"
+
+/ {
+       compatible = "glinet,ar300m-nand", "qca,qca9531";
+       model = "GL.iNet GL-AR300M (NAND)";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "winbond,w25q128", "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@1 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@2 {
+                               label = "reserved";
+                               reg = <0x050000 0xfa0000>;
+                       };
+
+                       art: partition@3 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                       };
+               };
+       };
+
+       flash@1 {
+               compatible = "spinand,mt29f";
+               reg = <1>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "kernel";
+                               reg = <0x000000 0x0200000>;
+                       };
+
+                       partition@1 {
+                               label = "ubi";
+                               reg = <0x200000 0x7e00000>;
+                       };
+               };
+       };
+};
diff --git a/target/linux/ath79/dts/qca9531_glinet_ar300m-nor.dts b/target/linux/ath79/dts/qca9531_glinet_ar300m-nor.dts
new file mode 100644 (file)
index 0000000..36903bd
--- /dev/null
@@ -0,0 +1,50 @@
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9531_glinet_ar300m.dtsi"
+
+/ {
+       compatible = "glinet,ar300m-nor", "qca,qca9531";
+       model = "GL.iNet GL-AR300M (NOR)";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <0>;
+
+       flash@0 {
+               compatible = "winbond,w25q128", "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@1 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@2 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x050000 0xfa0000>;
+                       };
+
+                       art: partition@3 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                       };
+               };
+       };
+};
index 986177df018781e3f889c42a29719da19512e1c0..34fcfb32c338c2b0ddeecafc7bdc3296eeb4e2ea 100644 (file)
@@ -6,9 +6,6 @@
 #include "qca953x.dtsi"
 
 / {
 #include "qca953x.dtsi"
 
 / {
-       compatible = "glinet,ar300m", "qca,qca9531";
-       model = "GL.iNet GL-AR300M";
-
        keys {
                compatible = "gpio-keys-polled";
                poll-interval = <20>;
        keys {
                compatible = "gpio-keys-polled";
                poll-interval = <20>;
diff --git a/target/linux/ath79/dts/qca9531_glinet_ar300m_nand.dts b/target/linux/ath79/dts/qca9531_glinet_ar300m_nand.dts
deleted file mode 100644 (file)
index f188ac6..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-/dts-v1/;
-
-#include "qca9531_glinet_ar300m.dtsi"
-
-&spi {
-       status = "okay";
-       num-cs = <1>;
-
-       flash@0 {
-               compatible = "winbond,w25q128", "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@1 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                       };
-
-                       partition@2 {
-                               label = "reserved";
-                               reg = <0x050000 0xfa0000>;
-                       };
-
-                       art: partition@3 {
-                               label = "art";
-                               reg = <0xff0000 0x010000>;
-                       };
-               };
-       };
-
-       flash@1 {
-               compatible = "spinand,mt29f";
-               reg = <1>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "kernel";
-                               reg = <0x000000 0x0200000>;
-                       };
-
-                       partition@1 {
-                               label = "ubi";
-                               reg = <0x200000 0x7e00000>;
-                       };
-               };
-       };
-};
diff --git a/target/linux/ath79/dts/qca9531_glinet_ar300m_nor.dts b/target/linux/ath79/dts/qca9531_glinet_ar300m_nor.dts
deleted file mode 100644 (file)
index 1128e2d..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca9531_glinet_ar300m.dtsi"
-
-&spi {
-       status = "okay";
-       num-cs = <0>;
-
-       flash@0 {
-               compatible = "winbond,w25q128", "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@1 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                       };
-
-                       partition@2 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x050000 0xfa0000>;
-                       };
-
-                       art: partition@3 {
-                               label = "art";
-                               reg = <0xff0000 0x010000>;
-                       };
-               };
-       };
-};
index f0c76911024f2559ae4dbfc97f6068793b737a12..d5d527fa44412c886244368adc217200815fa665 100644 (file)
@@ -174,14 +174,14 @@ define Device/glinet_ar150
 endef
 TARGET_DEVICES += glinet_ar150
 
 endef
 TARGET_DEVICES += glinet_ar150
 
-define Device/glinet_ar300m_nor
+define Device/glinet_ar300m-nor
   ATH_SOC := qca9531
   DEVICE_TITLE := GL.iNet GL-AR300M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar300m
 endef
   ATH_SOC := qca9531
   DEVICE_TITLE := GL.iNet GL-AR300M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar300m
 endef
-TARGET_DEVICES += glinet_ar300m_nor
+TARGET_DEVICES += glinet_ar300m-nor
 
 define Device/glinet_gl-x750
   ATH_SOC := qca9531
 
 define Device/glinet_gl-x750
   ATH_SOC := qca9531
index 1852ca41793b3532728e2c6247464a29e94f7bdd..e5694b8af454f149eca6feb542311a3422475600 100644 (file)
@@ -1,4 +1,4 @@
-define Device/glinet_ar300m_nand
+define Device/glinet_ar300m-nand
   ATH_SOC := qca9531
   DEVICE_TITLE := GL-AR300M (NAND)
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
   ATH_SOC := qca9531
   DEVICE_TITLE := GL-AR300M (NAND)
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
@@ -10,4 +10,4 @@ define Device/glinet_ar300m_nand
   IMAGE/sysupgrade.tar := sysupgrade-tar
   IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
   IMAGE/sysupgrade.tar := sysupgrade-tar
   IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
-TARGET_DEVICES += glinet_ar300m_nand
+TARGET_DEVICES += glinet_ar300m-nand