buildroot: make it easier to build all kmods
authorJonas Gorski <jogo@openwrt.org>
Mon, 16 Mar 2015 11:51:54 +0000 (11:51 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 16 Mar 2015 11:51:54 +0000 (11:51 +0000)
Split out kmods from ALL to make it easier to create local builds that
are compatible kmod-wise with releases.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44830

config/Config-build.in
include/version.mk
scripts/metadata.pl

index 213609b8b2bf277659cd2e4eb1bf6d5046d6ead6..582724eff1a887127dc0f9407e426fe5c586c64b 100644 (file)
@@ -6,8 +6,12 @@
 
 menu "Global build settings"
 
+       config ALL_KMODS
+               bool "Select all kernel module packages by default"
+               default ALL
+
        config ALL
-               bool "Select all packages by default"
+               bool "Select all userspace packages by default"
                default n
 
        comment "General build options"
index 5cfeae235c59b982b855b8eead5ab8080fd97fb5..69141ff696a1b53eb8ce5839ba5e6296ec1bb65c 100644 (file)
@@ -53,7 +53,7 @@ $(lastword $(subst :, ,$(1)))
 endef
 
 VERSION_TAINT_SPECS := \
-       -ALL:no-all \
+       -ALL_KMODS:no-all \
        -IPV6:no-ipv6 \
        +USE_GLIBC:glibc \
        +USE_MKLIBS:mklibs \
index bfb9ab50e2eddead8caa8dcc11d2b689e56afbfd..92923ea07aa09a56acf82dbfeb04267410cf5c40 100755 (executable)
@@ -545,7 +545,11 @@ sub print_package_config_category($) {
                        print "\t\t".($pkg->{tristate} ? 'tristate' : 'bool')." $title\n";
                        print "\t\tdefault y if DEFAULT_".$pkg->{name}."\n";
                        unless ($pkg->{hidden}) {
-                               $pkg->{default} ||= "m if ALL";
+                               if ($pkg->{name} =~ /^kmod-/) {
+                                       $pkg->{default} ||= "m if ALL_KMODS";
+                               } else {
+                                       $pkg->{default} ||= "m if ALL";
+                               }
                        }
                        if ($pkg->{default}) {
                                foreach my $default (split /\s*,\s*/, $pkg->{default}) {