tools/coreutils: enable ginstall utility
authorFelix Fietkau <nbd@nbd.name>
Wed, 13 Jul 2022 15:48:31 +0000 (17:48 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 13 Jul 2022 15:57:34 +0000 (17:57 +0200)
For some reason, current coreutils version installed on x86 macOS via homebrew
have a bug, where at least the cc1 binary from gcc gets corrupted during install
to the staging dir.
Using the install utility from tools/coreutils fixes this

Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/coreutils/Makefile

index fc5c259d8fa2e51a5d984a2005a791638ed8ed75..87c9102fa6219c6ba2d334c3289b0e354e7b4614 100644 (file)
@@ -16,7 +16,7 @@ PKG_HASH:=4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
 
 HOST_BUILD_PARALLEL := 1
 
-BUILD_PROGRAMS = date readlink touch ln chown
+BUILD_PROGRAMS = date readlink touch ln chown ginstall
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -31,7 +31,8 @@ HOST_MAKE_FLAGS += \
 
 define Host/Install
        $(INSTALL_DIR) $(1)/bin
-       $(CP) $(patsubst %,$(HOST_BUILD_DIR)/%,$(BUILD_BINS)) $(1)/bin/
+       $(INSTALL_BIN) $(patsubst %,$(HOST_BUILD_DIR)/%,$(BUILD_BINS)) $(1)/bin/
+       ln -sf ginstall $(1)/bin/install
 endef
 
 $(eval $(call HostBuild))