ath79: bsap18x0: pad rootfs image
authorTomasz Maciej Nowak <tmn505@gmail.com>
Tue, 7 Jun 2022 13:58:30 +0000 (15:58 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 24 Jun 2022 15:10:24 +0000 (17:10 +0200)
This image is supposed to be written with help of bootloader to the
flash, but as it stands, it's not aligned to block size and RedBoot will
happily create non-aligned partition size in FIS directory. This could
lead to kernel to mark the partition as read-only, therefore pad the
image to block erase size boundary.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
target/linux/ath79/image/generic.mk

index 96b073b1b5f8e65b9becdcc557d483626e03d89d..effa3af841388215f0d87ba790b027c0728a3dc1 100644 (file)
@@ -209,7 +209,7 @@ define Device/adtran_bsap1880
   IMAGE_SIZE := 11200k
   IMAGES += kernel.bin rootfs.bin
   IMAGE/kernel.bin := append-kernel
-  IMAGE/rootfs.bin := append-rootfs | pad-rootfs
+  IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to $$(BLOCKSIZE)
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
        check-size | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef