odhcp6c: add client fqdn and reconfigure options
authorpacien <pacien.trangirard@pacien.net>
Thu, 6 Sep 2018 13:56:17 +0000 (15:56 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 8 Sep 2018 19:46:07 +0000 (21:46 +0200)
Allowing DHCPV6_CLIENT_FQDN and DHCPV6_ACCEPT_RECONFIGURE to be turned off.
Defaulting to false, former behavior remains unchanged.

Signed-off-by: pacien <pacien.trangirard@pacien.net>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
(cherry picked from commit ef01c1d308d1cb200fc14ab49f0d3d0a07e1a9fe)

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index 7f5f745fb85a7f3bbadbe2c4471b0b2732e010e3..c9a893b57bdff4d5aed603889aad74f87152070d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_RELEASE:=14
+PKG_RELEASE:=14.1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
index 7f67f8b1bebe4953bb235a540f00d1f8e5581560..cf6847f29e212ba7b46de4805406ab1a5384a952 100755 (executable)
@@ -17,6 +17,8 @@ proto_dhcpv6_init_config() {
        proto_config_add_string 'extendprefix:bool'
        proto_config_add_string 'norelease:bool'
        proto_config_add_string 'noserverunicast:bool'
+       proto_config_add_string 'noclientfqdn:bool'
+       proto_config_add_string 'noacceptreconfig:bool'
        proto_config_add_array 'ip6prefix:list(ip6addr)'
        proto_config_add_string iface_dslite
        proto_config_add_string zone_dslite
@@ -51,8 +53,8 @@ proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease noserverunicast ip6prefix ip6prefixes iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone encaplimit_dslite encaplimit_map soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
-       json_get_vars reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease noserverunicast iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass delegate zone_dslite zone_map zone_464xlat zone encaplimit_dslite encaplimit_map soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
+       local reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease noserverunicast noclientfqdn noacceptreconfig ip6prefix ip6prefixes iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone encaplimit_dslite encaplimit_map soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
+       json_get_vars reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease noserverunicast noclientfqdn noacceptreconfig iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass delegate zone_dslite zone_map zone_464xlat zone encaplimit_dslite encaplimit_map soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
        json_for_each_item proto_dhcpv6_add_prefix ip6prefix ip6prefixes
 
        # Configure
@@ -74,6 +76,10 @@ proto_dhcpv6_setup() {
 
        [ "$noserverunicast" = "1" ] && append opts "-U"
 
+       [ "$noclientfqdn" = "1" ] && append opts "-f"
+
+       [ "$noacceptreconfig" = "1" ] && append opts "-a"
+
        [ -n "$ifaceid" ] && append opts "-i$ifaceid"
 
        [ -n "$vendorclass" ] && append opts "-V$vendorclass"