add vfat/fat/msdos modules needed for usb mass storage devices, add lp/parport, neede...
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Thu, 17 Mar 2005 00:28:36 +0000 (00:28 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Thu, 17 Mar 2005 00:28:36 +0000 (00:28 +0000)
SVN-Revision: 384

openwrt/package/linux/Config.in
openwrt/package/linux/Makefile
openwrt/package/linux/control/kmod-lp.control [new file with mode: 0644]
openwrt/package/linux/control/kmod-vfat.control [new file with mode: 0644]
openwrt/package/linux/linux.config

index 99cb26f70efe8af15aa06a6b8db4d7eb16969379..599d9ec7976bb9fab80071f4aa319ef06fc018de 100644 (file)
@@ -43,6 +43,19 @@ config BR2_PACKAGE_KMOD_USB
          Kernel modules for USB/SCSI support
          Includes usb-storage and printer
 
+config BR2_PACKAGE_KMOD_VFAT
+       tristate "VFAT filesystem support"
+       default m
+       help
+         Kernel modules for VFAT filesystem support
+         useful for usb mass storage devices
+
+config BR2_PACKAGE_KMOD_LP
+       tristate "parallel port and lp support"
+       default m
+       help
+         Kernel modules for line printer and parallel port support
+
 config BR2_PACKAGE_KMOD_CRYPTO
        tristate "CryptoAPI modules"
        default m
index 5e9cba45f40671f9517c4430e373549675ee1e0d..458ad1d15e826358af546ad8180406357d434f1c 100644 (file)
@@ -50,6 +50,16 @@ $(eval $(call KMOD_template,USB,usb,\
        $(MODULES_DIR)/kernel/drivers/usb/*.o \
        $(MODULES_DIR)/kernel/drivers/usb/*/*.o \
 ))
+$(eval $(call KMOD_template,LP,lp,\
+       $(MODULES_DIR)/kernel/drivers/parport/parport.o \
+       $(MODULES_DIR)/kernel/drivers/parport/parport_pc.o \
+       $(MODULES_DIR)/kernel/drivers/char/lp.o \
+))
+$(eval $(call KMOD_template,VFAT,vfat,\
+       $(MODULES_DIR)/kernel/fs/vfat/vfat.o \
+       $(MODULES_DIR)/kernel/fs/fat/fat.o \
+       $(MODULES_DIR)/kernel/fs/msdos/msdos.o \
+))
 $(eval $(call KMOD_template,CRYPTO,crypto,\
        $(MODULES_DIR)/kernel/crypto/*.o \
 ))
diff --git a/openwrt/package/linux/control/kmod-lp.control b/openwrt/package/linux/control/kmod-lp.control
new file mode 100644 (file)
index 0000000..3799943
--- /dev/null
@@ -0,0 +1,8 @@
+Package: kmod-lp
+Priority: optional
+Section: sys
+Version: 2.4.29-1
+Architecture: mipsel
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: Kernel modules for parallel port support and line printer
diff --git a/openwrt/package/linux/control/kmod-vfat.control b/openwrt/package/linux/control/kmod-vfat.control
new file mode 100644 (file)
index 0000000..c44594a
--- /dev/null
@@ -0,0 +1,8 @@
+Package: kmod-vfat
+Priority: optional
+Section: sys
+Version: 2.4.29-1
+Architecture: mipsel
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: Kernel modules for VFAT filesystem support
index 4d2a7ef1c6bf3b204aec71a160df2d9e1590cfe6..3c94a5b618381a7a8267d25b030179239be93336 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Automatically generated make config: don't edit
+# Automatically generated by make menuconfig: don't edit
 #
 CONFIG_MIPS=y
 CONFIG_MIPS32=y
@@ -181,10 +181,6 @@ CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_CONCAT is not set
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_CMDLINE_PARTS is not set
-
-#
-# User Modules And Translation Layers
-#
 CONFIG_MTD_CHAR=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_FTL is not set
@@ -250,10 +246,6 @@ CONFIG_MTD_SFLASH=y
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_MTDRAM is not set
 # CONFIG_MTD_BLKMTD is not set
-
-#
-# Disk-On-Chip Device Drivers
-#
 # CONFIG_MTD_DOC1000 is not set
 # CONFIG_MTD_DOC2000 is not set
 # CONFIG_MTD_DOC2001 is not set
@@ -267,7 +259,21 @@ CONFIG_MTD_SFLASH=y
 #
 # Parallel port support
 #
-# CONFIG_PARPORT is not set
+CONFIG_PARPORT=m
+CONFIG_PARPORT_PC=m
+CONFIG_PARPORT_PC_CML1=m
+# CONFIG_PARPORT_SERIAL is not set
+# CONFIG_PARPORT_PC_FIFO is not set
+# CONFIG_PARPORT_PC_SUPERIO is not set
+# CONFIG_PARPORT_PC_PCMCIA is not set
+# CONFIG_PARPORT_AMIGA is not set
+# CONFIG_PARPORT_MFC3 is not set
+# CONFIG_PARPORT_ATARI is not set
+# CONFIG_PARPORT_GSC is not set
+# CONFIG_PARPORT_SUNBPP is not set
+# CONFIG_PARPORT_IP22 is not set
+# CONFIG_PARPORT_OTHER is not set
+# CONFIG_PARPORT_1284 is not set
 
 #
 # Plug and Play configuration
@@ -423,10 +429,6 @@ CONFIG_IP6_NF_TARGET_MARK=m
 # CONFIG_IP_SCTP is not set
 # CONFIG_ATM is not set
 CONFIG_VLAN_8021Q=y
-
-#
-#  
-#
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
 # CONFIG_DECNET is not set
@@ -511,20 +513,12 @@ CONFIG_NET_CLS_POLICE=y
 # SCSI support
 #
 CONFIG_SCSI=m
-
-#
-# SCSI support type (disk, tape, CD-ROM)
-#
 CONFIG_BLK_DEV_SD=m
 CONFIG_SD_EXTRA_DEVS=5
 # CONFIG_CHR_DEV_ST is not set
 # CONFIG_CHR_DEV_OSST is not set
 # CONFIG_BLK_DEV_SR is not set
 CONFIG_CHR_DEV_SG=m
-
-#
-# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
-#
 # CONFIG_SCSI_DEBUG_QUEUES is not set
 # CONFIG_SCSI_MULTI_LUN is not set
 # CONFIG_SCSI_CONSTANTS is not set
@@ -573,6 +567,8 @@ CONFIG_CHR_DEV_SG=m
 # CONFIG_SCSI_GENERIC_NCR5380 is not set
 # CONFIG_SCSI_INITIO is not set
 # CONFIG_SCSI_INIA100 is not set
+# CONFIG_SCSI_PPA is not set
+# CONFIG_SCSI_IMM is not set
 # CONFIG_SCSI_NCR53C406A is not set
 # CONFIG_SCSI_NCR53C7xx is not set
 # CONFIG_SCSI_SYM53C8XX_2 is not set
@@ -744,6 +740,10 @@ CONFIG_SERIAL_CONSOLE=y
 # CONFIG_SERIAL_NONSTANDARD is not set
 CONFIG_UNIX98_PTYS=y
 CONFIG_UNIX98_PTY_COUNT=128
+CONFIG_PRINTER=m
+# CONFIG_LP_CONSOLE is not set
+# CONFIG_PPDEV is not set
+# CONFIG_TIPAR is not set
 
 #
 # I2C support
@@ -760,14 +760,6 @@ CONFIG_UNIX98_PTY_COUNT=128
 # Joysticks
 #
 # CONFIG_INPUT_GAMEPORT is not set
-
-#
-# Input core support is needed for gameports
-#
-
-#
-# Input core support is needed for joysticks
-#
 # CONFIG_QIC02_TAPE is not set
 # CONFIG_IPMI_HANDLER is not set
 # CONFIG_IPMI_PANIC_EVENT is not set
@@ -994,24 +986,12 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 #
 CONFIG_USB=m
 # CONFIG_USB_DEBUG is not set
-
-#
-# Miscellaneous USB options
-#
 CONFIG_USB_DEVICEFS=y
 # CONFIG_USB_BANDWIDTH is not set
-
-#
-# USB Host Controller Drivers
-#
 # CONFIG_USB_EHCI_HCD is not set
 # CONFIG_USB_UHCI is not set
 # CONFIG_USB_UHCI_ALT is not set
 CONFIG_USB_OHCI=m
-
-#
-# USB Device Class drivers
-#
 # CONFIG_USB_AUDIO is not set
 # CONFIG_USB_EMI26 is not set
 # CONFIG_USB_BLUETOOTH is not set
@@ -1028,15 +1008,7 @@ CONFIG_USB_STORAGE_SDDR55=y
 CONFIG_USB_STORAGE_JUMPSHOT=y
 # CONFIG_USB_ACM is not set
 CONFIG_USB_PRINTER=m
-
-#
-# USB Human Interface Devices (HID)
-#
 # CONFIG_USB_HID is not set
-
-#
-#     Input core support is needed for USB HID input layer or HIDBP support
-#
 # CONFIG_USB_HIDINPUT is not set
 # CONFIG_USB_HIDDEV is not set
 # CONFIG_USB_KBD is not set
@@ -1045,47 +1017,23 @@ CONFIG_USB_PRINTER=m
 # CONFIG_USB_WACOM is not set
 # CONFIG_USB_KBTAB is not set
 # CONFIG_USB_POWERMATE is not set
-
-#
-# USB Imaging devices
-#
 # CONFIG_USB_DC2XX is not set
 # CONFIG_USB_MDC800 is not set
 # CONFIG_USB_SCANNER is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_HPUSBSCSI is not set
-
-#
-# USB Multimedia devices
-#
-
-#
-#   Video4Linux support is needed for USB Multimedia device support
-#
-
-#
-# USB Network adaptors
-#
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
 # CONFIG_USB_KAWETH is not set
 # CONFIG_USB_CATC is not set
 # CONFIG_USB_CDCETHER is not set
 # CONFIG_USB_USBNET is not set
-
-#
-# USB port drivers
-#
 # CONFIG_USB_USS720 is not set
 
 #
 # USB Serial Converter support
 #
 # CONFIG_USB_SERIAL is not set
-
-#
-# USB Miscellaneous drivers
-#
 # CONFIG_USB_RIO500 is not set
 # CONFIG_USB_AUERSWALD is not set
 # CONFIG_USB_TIGL is not set