kernel: add a workaround to rebuild vdso.so.dbg after genvdso
authorJo-Philipp Wich <jo@mein.io>
Fri, 29 Apr 2016 07:53:09 +0000 (09:53 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 29 Apr 2016 07:58:39 +0000 (09:58 +0200)
Currently the build fails with

  'arch/mips/vdso/vdso.so.dbg' already contains a '.MIPS.abiflags' section

if the file already exists from a prior build.

Add a makefile rule to force the rebuild of vdso.so.dbg if genvdso has
has been changed to workaround the failure.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch [new file with mode: 0644]

diff --git a/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
new file mode 100644 (file)
index 0000000..3d25e80
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
+ $(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
+-$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) FORCE
++$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) $(obj)/genvdso FORCE
+       $(call if_changed,vdsold)
+ $(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE