ar71xx: fix AVM package selection
authorDavid Bauer <mail@david-bauer.net>
Fri, 8 Jun 2018 19:41:25 +0000 (21:41 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 9 Jun 2018 11:45:29 +0000 (13:45 +0200)
The AVM package selection partially broke with the addition of the
FRITZ!Box 4020. This commit restores the intended behavior.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ar71xx/image/generic.mk

index e57f8a273135069fd80fc08de729f4cdb5452d15..05eeeebaad954e988b0738ddace403decba50267 100644 (file)
@@ -1318,7 +1318,7 @@ endef
 define Device/fritz300e
   $(call Device/AVM)
   DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
-  DEVICE_PACKAGES := rssileds -swconfig
+  DEVICE_PACKAGES += rssileds -swconfig
   BOARDNAME := FRITZ300E
   SUPPORTED_DEVICES := fritz300e
   IMAGE_SIZE := 15232k
@@ -1328,7 +1328,7 @@ TARGET_DEVICES += fritz300e
 define Device/fritz4020
   $(call Device/AVM)
   DEVICE_TITLE := AVM FRITZ!Box 4020
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
+  DEVICE_PACKAGES += kmod-usb-core kmod-usb2 kmod-usb-storage
   BOARDNAME := FRITZ4020
   SUPPORTED_DEVICES := fritz4020
   IMAGE_SIZE := 15232k