kernel: bump 4.14 to 4.14.128
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 20 Jun 2019 07:49:08 +0000 (09:49 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 20 Jun 2019 13:50:00 +0000 (15:50 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0436-Revert-rtc-pcf8523-properly-handle-oscillator-stop-b.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/backport-4.14/030-v4.17-0001-usb-dwc2-add-support-for-host-mode-external-vbus-sup.patch
target/linux/generic/backport-4.14/030-v4.17-0002-usb-dwc2-dwc2_vbus_supply_init-fix-error-check.patch
target/linux/generic/hack-4.14/930-crashlog.patch
target/linux/generic/pending-4.14/171-usb-dwc2-Fix-inefficient-copy-of-unaligned-buffers.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch
target/linux/oxnas/patches-4.14/999-libata-hacks.patch
target/linux/ramips/patches-4.14/0032-USB-dwc2-add-device_reset.patch

index 026dbaab100427536d1e2832565076911849f4dc..9c9e95d4f920410cbd1ab1e72ed703b88127fde8 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .180
 endif
 
 LINUX_VERSION-4.9 = .180
-LINUX_VERSION-4.14 = .127
+LINUX_VERSION-4.14 = .128
 LINUX_VERSION-4.19 = .48
 
 LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
 LINUX_VERSION-4.19 = .48
 
 LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
-LINUX_KERNEL_HASH-4.14.127 = d7464c2379cdee46548ae9f848671f4669d4003af4034f3f738f2f0511ec75b3
+LINUX_KERNEL_HASH-4.14.128 = e93c2c754f1f9c610314b2fe9f27a9636ad3a7f43983469bb8e0f44a531f2913
 LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index b68cef69d6fc5cac93cff99df1f8d14a1aa03fe2..5ebb2a06cb933f61103316fd2a924ac83a9bb0b6 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/rtc/rtc-pcf8523.c
 +++ b/drivers/rtc/rtc-pcf8523.c
 
 --- a/drivers/rtc/rtc-pcf8523.c
 +++ b/drivers/rtc/rtc-pcf8523.c
-@@ -178,8 +178,28 @@ static int pcf8523_rtc_read_time(struct
+@@ -198,8 +198,28 @@ static int pcf8523_rtc_read_time(struct
        if (err < 0)
                return err;
  
        if (err < 0)
                return err;
  
@@ -46,7 +46,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        tm->tm_sec = bcd2bin(regs[0] & 0x7f);
        tm->tm_min = bcd2bin(regs[1] & 0x7f);
  
        tm->tm_sec = bcd2bin(regs[0] & 0x7f);
        tm->tm_min = bcd2bin(regs[1] & 0x7f);
-@@ -215,7 +235,6 @@ static int pcf8523_rtc_set_time(struct d
+@@ -235,7 +255,6 @@ static int pcf8523_rtc_set_time(struct d
                return err;
  
        regs[0] = REG_SECONDS;
                return err;
  
        regs[0] = REG_SECONDS;
index 7053f61a0c269276a6ca735cb1def01382245f10..b60e9d32306ee93a04adb70d1f777b8379b8459d 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1941,7 +1941,8 @@ static const struct usb_device_id option
+@@ -1947,7 +1947,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index a17844f5e637adbfb850011870464f1dd30733c3..4d029ebfe239092acbf4e8fb2c72ad27371d30a9 100644 (file)
@@ -63,7 +63,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
  /**
   * dwc2_enable_host_interrupts() - Enables the Host mode interrupts
   *
  /**
   * dwc2_enable_host_interrupts() - Enables the Host mode interrupts
   *
-@@ -3342,6 +3359,7 @@ static void dwc2_conn_id_status_change(s
+@@ -3346,6 +3363,7 @@ static void dwc2_conn_id_status_change(s
  
        /* B-Device connector (Device Mode) */
        if (gotgctl & GOTGCTL_CONID_B) {
  
        /* B-Device connector (Device Mode) */
        if (gotgctl & GOTGCTL_CONID_B) {
@@ -71,7 +71,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
                /* Wait for switch to device mode */
                dev_dbg(hsotg->dev, "connId B\n");
                if (hsotg->bus_suspended) {
                /* Wait for switch to device mode */
                dev_dbg(hsotg->dev, "connId B\n");
                if (hsotg->bus_suspended) {
-@@ -4448,6 +4466,9 @@ static int _dwc2_hcd_start(struct usb_hc
+@@ -4455,6 +4473,9 @@ static int _dwc2_hcd_start(struct usb_hc
        }
  
        spin_unlock_irqrestore(&hsotg->lock, flags);
        }
  
        spin_unlock_irqrestore(&hsotg->lock, flags);
@@ -81,7 +81,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        return 0;
  }
  
        return 0;
  }
  
-@@ -4475,6 +4496,8 @@ static void _dwc2_hcd_stop(struct usb_hc
+@@ -4482,6 +4503,8 @@ static void _dwc2_hcd_stop(struct usb_hc
        clear_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
        spin_unlock_irqrestore(&hsotg->lock, flags);
  
        clear_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
        spin_unlock_irqrestore(&hsotg->lock, flags);
  
@@ -90,7 +90,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        usleep_range(1000, 3000);
  }
  
        usleep_range(1000, 3000);
  }
  
-@@ -4511,6 +4534,7 @@ static int _dwc2_hcd_suspend(struct usb_
+@@ -4518,6 +4541,7 @@ static int _dwc2_hcd_suspend(struct usb_
                hprt0 |= HPRT0_SUSP;
                hprt0 &= ~HPRT0_PWR;
                dwc2_writel(hprt0, hsotg->regs + HPRT0);
                hprt0 |= HPRT0_SUSP;
                hprt0 &= ~HPRT0_PWR;
                dwc2_writel(hprt0, hsotg->regs + HPRT0);
@@ -98,7 +98,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        }
  
        /* Enter hibernation */
        }
  
        /* Enter hibernation */
-@@ -4591,6 +4615,8 @@ static int _dwc2_hcd_resume(struct usb_h
+@@ -4598,6 +4622,8 @@ static int _dwc2_hcd_resume(struct usb_h
                spin_unlock_irqrestore(&hsotg->lock, flags);
                dwc2_port_resume(hsotg);
        } else {
                spin_unlock_irqrestore(&hsotg->lock, flags);
                dwc2_port_resume(hsotg);
        } else {
index 59ab805cf6723f3da33772bd28b12ed720b57f32..02b61fe84fe85bb53dcf774f48937844a3ef66f1 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
  
        return regulator_enable(hsotg->vbus_supply);
  }
  
        return regulator_enable(hsotg->vbus_supply);
  }
-@@ -4467,9 +4472,7 @@ static int _dwc2_hcd_start(struct usb_hc
+@@ -4474,9 +4479,7 @@ static int _dwc2_hcd_start(struct usb_hc
  
        spin_unlock_irqrestore(&hsotg->lock, flags);
  
  
        spin_unlock_irqrestore(&hsotg->lock, flags);
  
index 17ba187925553146f4b277c3d5c44e5a48678dc0..1479a4c06d0b9755901fb4b412636e8a07543834 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        depends on BROKEN || !FRV
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
        depends on BROKEN || !FRV
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
-@@ -112,6 +112,7 @@ obj-$(CONFIG_CONTEXT_TRACKING) += contex
+@@ -113,6 +113,7 @@ obj-$(CONFIG_CONTEXT_TRACKING) += contex
  obj-$(CONFIG_TORTURE_TEST) += torture.o
  
  obj-$(CONFIG_HAS_IOMEM) += memremap.o
  obj-$(CONFIG_TORTURE_TEST) += torture.o
  
  obj-$(CONFIG_HAS_IOMEM) += memremap.o
index 588b571e01a9bbe1ebc839b156e1fda1f9371daf..7f21fefc252e7889147bf93c3e66aa7fc0898ae4 100644 (file)
@@ -30,9 +30,9 @@ Signed-off-by: Antti Seppälä <a.seppala@gmail.com>
  
        if (!(urb->transfer_flags & URB_ALIGNED_TEMP_BUFFER))
                return;
  
        if (!(urb->transfer_flags & URB_ALIGNED_TEMP_BUFFER))
                return;
-@@ -2677,9 +2678,14 @@ static void dwc2_free_dma_aligned_buffer
-       memcpy(&stored_xfer_buffer, urb->transfer_buffer +
-              urb->transfer_buffer_length, sizeof(urb->transfer_buffer));
+@@ -2679,9 +2680,14 @@ static void dwc2_free_dma_aligned_buffer
+                        dma_get_cache_alignment()),
+              sizeof(urb->transfer_buffer));
  
 -      if (usb_urb_dir_in(urb))
 -              memcpy(stored_xfer_buffer, urb->transfer_buffer,
  
 -      if (usb_urb_dir_in(urb))
 -              memcpy(stored_xfer_buffer, urb->transfer_buffer,
index 392d41c94f291bab510f6469fbae64c5814b51dd..f59085b51cd70523c3574fc3c248dbad17dbd9dc 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5121,6 +5134,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5124,6 +5137,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -6022,6 +6038,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6025,6 +6041,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6043,6 +6062,12 @@ static void ata_host_release(struct devi
+@@ -6046,6 +6065,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6489,7 +6514,23 @@ int ata_host_register(struct ata_host *h
+@@ -6492,7 +6517,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index 7c11e2c84b85a5dd4de4f88e380623a7c47c3140..973146cedf2727749b3d917add1a46ccb7aac58f 100644 (file)
@@ -93,7 +93,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
  #include "io-pgtable.h"
  #include "arm-smmu-regs.h"
  
  #include "io-pgtable.h"
  #include "arm-smmu-regs.h"
-@@ -1465,6 +1466,8 @@ static struct iommu_group *arm_smmu_devi
+@@ -1474,6 +1475,8 @@ static struct iommu_group *arm_smmu_devi
  
        if (dev_is_pci(dev))
                group = pci_device_group(dev);
  
        if (dev_is_pci(dev))
                group = pci_device_group(dev);
@@ -102,7 +102,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        else
                group = generic_device_group(dev);
  
        else
                group = generic_device_group(dev);
  
-@@ -2043,6 +2046,10 @@ static void arm_smmu_bus_init(void)
+@@ -2052,6 +2055,10 @@ static void arm_smmu_bus_init(void)
                bus_set_iommu(&pci_bus_type, &arm_smmu_ops);
        }
  #endif
                bus_set_iommu(&pci_bus_type, &arm_smmu_ops);
        }
  #endif
index 382a16329aae3dff1e16b91abaef6ad5751708f4..29132befb500ccb096532179f0670f989ee97d12 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5128,6 +5136,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5131,6 +5139,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -5173,6 +5184,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5176,6 +5187,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
index 18576562410ba8f65643055d7a3b7eba18c5fb7c..c04e2db6615719df410468e8622ebeb9427f713f 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <linux/usb/hcd.h>
  #include <linux/usb/ch11.h>
  
  #include <linux/usb/hcd.h>
  #include <linux/usb/ch11.h>
-@@ -5206,6 +5207,8 @@ int dwc2_hcd_init(struct dwc2_hsotg *hso
+@@ -5215,6 +5216,8 @@ int dwc2_hcd_init(struct dwc2_hsotg *hso
  
        retval = -ENOMEM;
  
  
        retval = -ENOMEM;