ramips: add additional support for MQmaker WiTi board
authorJohn Crispin <john@openwrt.org>
Fri, 11 Dec 2015 15:04:13 +0000 (15:04 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 11 Dec 2015 15:04:13 +0000 (15:04 +0000)
The board is based on mt7621AT cpu, and has 16mb nor flash, 256mb of ram,
2 sata ports, microsd card slot, 1 USB 3.0 port and at least one 2.4 and
one 5 ghz antenna.

This is the 6th submission that adds support for XHCI in the device tree
file, along with switching the location of the 2 radio's and addition of
the kmod-i2c-mt7621 in the default packages of the profile.

Signed-off-by: Sebastian Careba <nitroshift@yahoo.com>
SVN-Revision: 47845

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WITI.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7621/profiles/mqmaker.mk [new file with mode: 0644]

index aee0e724e30390ee44c6f626e69eef7a04b2046b..dce6002e127d2de9f6211a551d18ceb6e593bc13 100755 (executable)
@@ -78,6 +78,7 @@ ramips_setup_interfaces()
        wf-2881|\
        whr-300hp2|\
        whr-600d|\
+       witi|\
        wsr-1166|\
        wsr-600|\
        wt1520|\
index 3940a54845ee9654b3c46c01af8c19694b430cb4..3e8a33186f6fe2d644500f205352a8acb7230781 100644 (file)
@@ -162,6 +162,7 @@ get_status_led() {
                status_led="$board:green:security"
                ;;
        w306r-v20|\
+       witi|\
        zbt-wr8305rt)
                status_led="$board:green:sys"
                ;;
index 92e13c034fb65f9a91283dfe66dce9f965bfdbeb..c002b975d7afe8437c5534ebdd26ee954a7a1a50 100755 (executable)
@@ -391,6 +391,9 @@ ramips_board_detect() {
        *"WHR-G300N")
                name="whr-g300n"
                ;;
+       *"WiTi")
+                name="witi"
+               ;;
        *"WIZARD 8800")
                name="wizard8800"
                ;;
index 073593ad38f4e0a6fc791d97068565ead48badcd..4ec3008b3e09b6c875758d559c6a6e67dbf563e5 100755 (executable)
@@ -113,6 +113,7 @@ platform_check_image() {
        whr-300hp2|\
        whr-600d|\
        whr-g300n|\
+       witi|\
        wizfi630a|\
        wl-330n|\
        wl-330n3g|\
diff --git a/target/linux/ramips/dts/WITI.dts b/target/linux/ramips/dts/WITI.dts
new file mode 100644 (file)
index 0000000..9b03147
--- /dev/null
@@ -0,0 +1,146 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+/ {
+       compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+       model = "MQmaker WiTi";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x10000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       xhci@1E1C0000 {
+               status = "okay";
+       };
+
+       palmbus@1E000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "jedec,spi-nor";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+
+               i2c@900 {
+                       compatible = "ralink,i2c-mt7621";
+                       reg = <0x900 0x100>;
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&i2c_pins>;
+                       status = "okay";
+
+                       pcf8563: rtc@51 {
+                               status = "okay";
+                               compatible = "nxp,pcf8563";
+                               reg = <0x51>;
+                       };
+               };
+       };
+
+       pcie@1e140000 {
+               status = "okay";
+
+               pcie0 {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+
+               pcie1 {
+                       mt76@1,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x0000>;
+                               mediatek,5ghz = <0>;
+                       };
+               };
+       };
+
+       ethernet@1e100000 {
+               mtd-mac-address = <&factory 0xe000>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "witi:green:power";
+                       gpios = <&gpio0 25 1>;
+               };
+
+               sys {
+                       label = "witi:green:sys";
+                       gpios = <&gpio0 24 1>;
+               };
+
+               internet {
+                       label = "witi:green:internet";
+                       gpios = <&gpio0 23 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "wdt", "rgmii2", "jtag", "mdio";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+};
index 01e3fcbf119a6490f4f03debe0df1a92c45396d4..63d622222351afcd3a8e2b9784a5938692da3a8b 100644 (file)
@@ -954,7 +954,7 @@ endif
 #
 
 ifeq ($(SUBTARGET),mt7621)
-  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
+  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 witi wf-2881 zbt-wg2626
 endif
 
 define Device/mt7621
@@ -1004,6 +1004,11 @@ define Device/sap-g3200u3
   DTS := SAP-G3200U3
 endef
 
+define Device/witi
+  DTS := WITI
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
 define Device/zbt-wg2626
   DTS := ZBT-WG2626
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
diff --git a/target/linux/ramips/mt7621/profiles/mqmaker.mk b/target/linux/ramips/mt7621/profiles/mqmaker.mk
new file mode 100644 (file)
index 0000000..ae35e7d
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/witi
+       NAME:=MQmaker WiTi
+       FEATURES+=rtc
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+               kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+               kmod-rtc-pcf8563 kmod-i2c-mt7621
+endef
+
+define Profile/witi/Description
+       Package set compatible with MQmaker WiTi board.
+endef
+$(eval $(call Profile,witi))