hostapd: wpas: add missing config symbols
authorDavid Bauer <mail@david-bauer.net>
Wed, 28 Oct 2020 02:17:11 +0000 (03:17 +0100)
committerDavid Bauer <mail@david-bauer.net>
Wed, 28 Oct 2020 02:25:25 +0000 (03:25 +0100)
This adds missing config symbols for interworking as well as Hotspot 2.0
to the wpa_supplicant-full configuration.

These symbols were added to the hostapd-full configuration prior to this
commit. Without adding them to the wpa_supplicant configuration,
building of wpad-full fails.

Thanks to Rene for reaching out on IRC.

Fixes: commit be9694aaa297 ("hostapd: add UCI support for Hotspot 2.0")
Fixes: commit 838b412cb527 ("hostapd: add interworking support")
Signed-off-by: David Bauer <mail@david-bauer.net>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/wpa_supplicant-full.config

index 4498fbde5c9d3e5d1321b64fda8ef61441535d87..bb20b7bcd9eeafaa376d84c4aa47be7203cbd56a 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=13
+PKG_RELEASE:=14
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 982f4d5534c5a3d77830907b700928d6521bec8b..4dd3e550a68dd85f81e00141abbe8c1b571e9c61 100644 (file)
@@ -490,10 +490,10 @@ CONFIG_WNM=y
 # This can be used to enable functionality to improve interworking with
 # external networks (GAS/ANQP to learn more about the networks and network
 # selection based on available credentials).
 # This can be used to enable functionality to improve interworking with
 # external networks (GAS/ANQP to learn more about the networks and network
 # selection based on available credentials).
-#CONFIG_INTERWORKING=y
+CONFIG_INTERWORKING=y
 
 # Hotspot 2.0
 
 # Hotspot 2.0
-#CONFIG_HS20=y
+CONFIG_HS20=y
 
 # Enable interface matching in wpa_supplicant
 #CONFIG_MATCH_IFACE=y
 
 # Enable interface matching in wpa_supplicant
 #CONFIG_MATCH_IFACE=y