ath79: harmonize model names for Ubiquiti devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 15 Jul 2020 16:41:57 +0000 (18:41 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 15 Jul 2020 16:41:57 +0000 (18:41 +0200)
This harmonizes the model names for the ath79 Ubiquiti devices by
applying a few minor cosmetic adjustments:

- Removes hyphens where they are not found in the product names
  (Ubiquiti uses hyphens only for the abbreviated version names
  like UAP-AC-PRO which we don't use anyway.)

- Add (XM) suffix for DTS model strings to help with distinguishing
  them from their XW counterparts.

- Remove DEVICE_VARIANT for LAP-120 which actually was an alternate
  device name.

- Generally make DTS model names and those from generic-ubnt.mk
  more consistent.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
17 files changed:
target/linux/ath79/dts/ar7161_ubnt_routerstation.dts
target/linux/ath79/dts/ar7240_ubnt_bullet-m-ar7240.dts
target/linux/ath79/dts/ar7241_ubnt_airrouter.dts
target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
target/linux/ath79/dts/ar7241_ubnt_nanobridge-m.dts
target/linux/ath79/dts/ar7241_ubnt_nanostation-loco-m.dts
target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts
target/linux/ath79/dts/ar7241_ubnt_powerbridge-m.dts
target/linux/ath79/dts/ar7241_ubnt_rocket-m.dts
target/linux/ath79/dts/ar7241_ubnt_unifi.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts
target/linux/ath79/image/generic-ubnt.mk

index 63b46b9c7914bc85dc365046a31eb28ab5d969bb..d3e6315306a1ce0f30337869fa2a5845dc2fb355 100644 (file)
@@ -5,7 +5,7 @@
 
 / {
        compatible = "ubnt,routerstation", "qca,ar7161";
 
 / {
        compatible = "ubnt,routerstation", "qca,ar7161";
-       model = "Ubiquiti Networks RouterStation";
+       model = "Ubiquiti RouterStation";
 };
 
 &eth0 {
 };
 
 &eth0 {
index 58b35f5c8b8be724918ed5f9e7828bddda4cfd09..73626f1ff4b40b4b03e7e412fe6f65646b154667 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,bullet-m-ar7240", "ubnt,xm", "qca,ar7240";
 
 / {
        compatible = "ubnt,bullet-m-ar7240", "ubnt,xm", "qca,ar7240";
-       model = "Ubiquiti Bullet M XM (AR7240)";
+       model = "Ubiquiti Bullet M (XM AR7240)";
 };
 
 &eth0 {
 };
 
 &eth0 {
index dd2421da8e8424e22e69eef1da96120c98935625..9da1c45b478628b33116e9a3be78fc36f29b42ad 100644 (file)
@@ -6,7 +6,7 @@
 
 / {
        compatible = "ubnt,airrouter", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,airrouter", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti AirRouter";
+       model = "Ubiquiti AirRouter (XM)";
 
        aliases {
                led-boot = &led_globe;
 
        aliases {
                led-boot = &led_globe;
index 0e2183c27d5a1395693625695655887bfc0eece6..261ee5435ed52b5088558baa32e6b4aece320a9e 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,bullet-m-ar7241", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,bullet-m-ar7241", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Bullet M XM (AR7241)";
+       model = "Ubiquiti Bullet M (XM AR7241)";
 };
 
 &eth1 {
 };
 
 &eth1 {
index 005ef27caaa2be500353c8418a363fc07e9da92f..4c4fd19d32ff035387e1cf5dea66cd66abcb36b6 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,nanobridge-m", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,nanobridge-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti NanoBridge M";
+       model = "Ubiquiti NanoBridge M (XM)";
 };
 
 &eth1 {
 };
 
 &eth1 {
index 60d5a21a2241c913ca9cb492384954c7b0529f57..4ccb1d50a7edb39f2de7a96356eb3cd068fe3c82 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,nanostation-loco-m", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,nanostation-loco-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Nanostation Loco M";
+       model = "Ubiquiti Nanostation Loco M (XM)";
 };
 
 &eth1 {
 };
 
 &eth1 {
index 82344bb5ea001e56e3e6eaddde31fc01d1a4ee33..fff4ec7042686d02bf93e3568d08e1e4705aa923 100644 (file)
@@ -7,5 +7,5 @@
 
 / {
        compatible = "ubnt,nanostation-m", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,nanostation-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Nanostation M";
+       model = "Ubiquiti Nanostation M (XM)";
 };
 };
index d05aca3e67389e1f133e11c37ccf9e40723d9297..4bb13e618cae419ccf0e9a26cf52b9c738cbced5 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,picostation-m", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,picostation-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Picostation M";
+       model = "Ubiquiti Picostation M (XM)";
 };
 
 &eth1 {
 };
 
 &eth1 {
index 3bf9ca4a907801850ee6e72ec77039c8f7b8b579..e14bfbfa8d37c436624616764f5cdbd9722aeea2 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,powerbridge-m", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,powerbridge-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti PowerBridge M";
+       model = "Ubiquiti PowerBridge M (XM)";
 };
 
 &eth1 {
 };
 
 &eth1 {
index 9e342177e23546a76bcb9d5d1f0ed036e20e5d1f..3e716dec6c5fe711ef0ed94535640a30dc685c94 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "ubnt,rocket-m", "ubnt,xm", "qca,ar7241";
 
 / {
        compatible = "ubnt,rocket-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Rocket M";
+       model = "Ubiquiti Rocket M (XM)";
 };
 
 &eth1 {
 };
 
 &eth1 {
index 5f12fd581b767b67841e04dfa3669044c70a7155..e7369f0dbf4aeebd3c0ffb2e2fabcdbcb334de20 100644 (file)
@@ -8,7 +8,7 @@
 
 / {
        compatible = "ubnt,unifi", "qca,ar7241";
 
 / {
        compatible = "ubnt,unifi", "qca,ar7241";
-       model = "Ubiquiti UniFi AP";
+       model = "Ubiquiti UniFi";
 
        aliases {
                led-boot = &led_dome_green;
 
        aliases {
                led-boot = &led_dome_green;
index 7b9fa0701b8f8f7c8588cabbecf1b85500ce2fe0..4ab4197a872682df2b1335807aca254d404a9e49 100644 (file)
@@ -5,5 +5,5 @@
 
 / {
        compatible = "ubnt,unifiac-lite", "qca,qca9563";
 
 / {
        compatible = "ubnt,unifiac-lite", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-LITE";
+       model = "Ubiquiti UniFi AC Lite";
 };
 };
index a1e542ada6160f06b0aa86d75fb679fd3e985050..3128081b55c36910661f1056abe152c60a52bb91 100644 (file)
@@ -5,5 +5,5 @@
 
 / {
        compatible = "ubnt,unifiac-lr", "qca,qca9563";
 
 / {
        compatible = "ubnt,unifiac-lr", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-LR";
+       model = "Ubiquiti UniFi AC LR";
 };
 };
index 9d80217d4e94a70d031e12ff17c9d3c4b79c87b8..97d9763049486a0acf89ae37716c05e89c6e0a8f 100644 (file)
@@ -5,5 +5,5 @@
 
 / {
        compatible = "ubnt,unifiac-mesh-pro", "qca,qca9563";
 
 / {
        compatible = "ubnt,unifiac-mesh-pro", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-MESH PRO";
+       model = "Ubiquiti UniFi AC Mesh Pro";
 };
 };
index 6eed56bb6cf3bedba21506eca5677f4c3667b0df..b3d652bdfaef8fa9bbd5ceb2a5645c0e343b36c0 100644 (file)
@@ -5,5 +5,5 @@
 
 / {
        compatible = "ubnt,unifiac-mesh", "qca,qca9563";
 
 / {
        compatible = "ubnt,unifiac-mesh", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-MESH";
+       model = "Ubiquiti UniFi AC Mesh";
 };
 };
index 41449bbfc3694bce53983a781875c39011647965..48c9e105e2aeac99539a4dbe84b77c9dacaaeeb5 100644 (file)
@@ -5,7 +5,7 @@
 
 / {
        compatible = "ubnt,unifiac-pro", "qca,qca9563";
 
 / {
        compatible = "ubnt,unifiac-pro", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-PRO";
+       model = "Ubiquiti UniFi AC Pro";
 };
 
 &usb_phy0 {
 };
 
 &usb_phy0 {
index e9202eadf7e63ceef2ca680192fe337dc4b1f026..55d98ce5085a8308948bcba544c6e2a8c56e91ef 100644 (file)
@@ -125,7 +125,7 @@ TARGET_DEVICES += ubnt_airrouter
 define Device/ubnt_bullet-m-ar7240
   $(Device/ubnt-xm)
   SOC := ar7240
 define Device/ubnt_bullet-m-ar7240
   $(Device/ubnt-xm)
   SOC := ar7240
-  DEVICE_MODEL := Bullet-M
+  DEVICE_MODEL := Bullet M
   DEVICE_VARIANT := XM (AR7240)
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += bullet-m
   DEVICE_VARIANT := XM (AR7240)
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += bullet-m
@@ -135,7 +135,7 @@ TARGET_DEVICES += ubnt_bullet-m-ar7240
 define Device/ubnt_bullet-m-ar7241
   $(Device/ubnt-xm)
   SOC := ar7241
 define Device/ubnt_bullet-m-ar7241
   $(Device/ubnt-xm)
   SOC := ar7241
-  DEVICE_MODEL := Bullet-M
+  DEVICE_MODEL := Bullet M
   DEVICE_VARIANT := XM (AR7241)
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
   DEVICE_VARIANT := XM (AR7241)
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
@@ -144,7 +144,7 @@ TARGET_DEVICES += ubnt_bullet-m-ar7241
 
 define Device/ubnt_bullet-m-xw
   $(Device/ubnt-xw)
 
 define Device/ubnt_bullet-m-xw
   $(Device/ubnt-xw)
-  DEVICE_MODEL := Bullet-M
+  DEVICE_MODEL := Bullet M
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += bullet-m-xw
 endef
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += bullet-m-xw
 endef
@@ -165,8 +165,7 @@ TARGET_DEVICES += ubnt_edgeswitch-8xp
 
 define Device/ubnt_lap-120
   $(Device/ubnt-wa)
 
 define Device/ubnt_lap-120
   $(Device/ubnt-wa)
-  DEVICE_MODEL := LiteAP ac
-  DEVICE_VARIANT := LAP-120
+  DEVICE_MODEL := LiteAP ac (LAP-120)
   DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
 endef
 TARGET_DEVICES += ubnt_lap-120
   DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
 endef
 TARGET_DEVICES += ubnt_lap-120
@@ -281,7 +280,7 @@ TARGET_DEVICES += ubnt_powerbridge-m
 define Device/ubnt_rocket-m
   $(Device/ubnt-xm)
   SOC := ar7241
 define Device/ubnt_rocket-m
   $(Device/ubnt-xm)
   SOC := ar7241
-  DEVICE_MODEL := Rocket-M
+  DEVICE_MODEL := Rocket M
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += rocket-m
 endef
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += rocket-m
 endef
@@ -337,35 +336,35 @@ endef
 
 define Device/ubnt_unifiac-lite
   $(Device/ubnt_unifiac)
 
 define Device/ubnt_unifiac-lite
   $(Device/ubnt_unifiac)
-  DEVICE_MODEL := UniFi AC-Lite
+  DEVICE_MODEL := UniFi AC Lite
   SUPPORTED_DEVICES += unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lite
 
 define Device/ubnt_unifiac-lr
   $(Device/ubnt_unifiac)
   SUPPORTED_DEVICES += unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lite
 
 define Device/ubnt_unifiac-lr
   $(Device/ubnt_unifiac)
-  DEVICE_MODEL := UniFi AC-LR
+  DEVICE_MODEL := UniFi AC LR
   SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lr
 
 define Device/ubnt_unifiac-mesh
   $(Device/ubnt_unifiac)
   SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lr
 
 define Device/ubnt_unifiac-mesh
   $(Device/ubnt_unifiac)
-  DEVICE_MODEL := UniFi AC-Mesh
+  DEVICE_MODEL := UniFi AC Mesh
   SUPPORTED_DEVICES += unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh
 
 define Device/ubnt_unifiac-mesh-pro
   $(Device/ubnt_unifiac)
   SUPPORTED_DEVICES += unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh
 
 define Device/ubnt_unifiac-mesh-pro
   $(Device/ubnt_unifiac)
-  DEVICE_MODEL := UniFi AC-Mesh Pro
+  DEVICE_MODEL := UniFi AC Mesh Pro
   SUPPORTED_DEVICES += unifiac-pro
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh-pro
 
 define Device/ubnt_unifiac-pro
   $(Device/ubnt_unifiac)
   SUPPORTED_DEVICES += unifiac-pro
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh-pro
 
 define Device/ubnt_unifiac-pro
   $(Device/ubnt_unifiac)
-  DEVICE_MODEL := UniFi AC-Pro
+  DEVICE_MODEL := UniFi AC Pro
   DEVICE_PACKAGES += kmod-usb2
   SUPPORTED_DEVICES += unifiac-pro
 endef
   DEVICE_PACKAGES += kmod-usb2
   SUPPORTED_DEVICES += unifiac-pro
 endef