ipq40xx: remove block- and pagesize from FB4040
authorDavid Bauer <mail@david-bauer.net>
Sat, 10 Mar 2018 09:49:15 +0000 (10:49 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 14 Mar 2018 18:04:51 +0000 (19:04 +0100)
This removes the block- and pagesize from the FritzBox 4040
image description, fixing incorrectly working sysupgrade.

With this commit, the default values for block- and pagesize are
used.

Signed-off-by: David Bauer <mail@david-bauer.net>
[chunkeey@gmail.com: removed 105-mtd-nor-add-mx25l25635f.patch as well]
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-4.14/105-mtd-nor-add-mx25l25635f.patch [deleted file]

index eb26082be7aec9331367a142316db077035c41f4..41f396b83976651d99f528554eb37090ec4f0081 100644 (file)
@@ -34,8 +34,6 @@ endef
 define Device/avm_fritzbox-4040
        $(call Device/FitImageLzma)
        DEVICE_DTS := qcom-ipq4019-fritz4040
-       BLOCKSIZE := 4k
-       PAGESIZE := 256
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
diff --git a/target/linux/ipq40xx/patches-4.14/105-mtd-nor-add-mx25l25635f.patch b/target/linux/ipq40xx/patches-4.14/105-mtd-nor-add-mx25l25635f.patch
deleted file mode 100644 (file)
index ea9d911..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Subject: mtd: spi-nor: add mx25l25635f with SECT_4K
-
-This patch fixes an issue with the creation of the
-ubi volume on the AVM FRITZ!Box 4040. The mx25l25635f
-and mx25l25635e support SECT_4K which will set the
-erase size to 4K. This is used by ubi to calculate
-VID header offsets. Without this, uboot and linux
-disagrees about the layout and refuse to attach
-the ubi volume created by the other.
-
----
---- a/drivers/mtd/spi-nor/spi-nor.c
-+++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1023,7 +1023,7 @@ static const struct flash_info spi_nor_i
-       { "mx25u6435f",  INFO(0xc22537, 0, 64 * 1024, 128, SECT_4K) },
-       { "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
-       { "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
--      { "mx25l25635e", INFO(0xc22019, 0, 64 * 1024, 512, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
-+      { "mx25l25635f", INFO(0xc22019, 0, 64 * 1024, 512, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ | SECT_4K) },
-       { "mx25u25635f", INFO(0xc22539, 0, 64 * 1024, 512, SECT_4K | SPI_NOR_4B_OPCODES) },
-       { "mx25l25655e", INFO(0xc22619, 0, 64 * 1024, 512, 0) },
-       { "mx66l51235l", INFO(0xc2201a, 0, 64 * 1024, 1024, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },